New types (related to Request and Response) generated importing WSDL

I’m facinf a strange issue getting wsdl in a “Soap request”.

When I click get button, Uipath creates an argument with same name of operation instead of inputs mapping request fields. More on variable type it’s possibile to see new types that are mapping request and response.
I tried to make a request declaring a variable of ZWsTriplettaRequest type and filling fields one by one.
When I run I receive the error:

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
System.Xaml.XamlObjectWriterException: Cannot create unknown type ‘{}Variable({clr-namespace:;assembly=bsanir5t}ZWsTripletta)’.

Has anyone faced similar issue?



Hi @supermg

Welcome to our UiPath Forum! :slight_smile:

Which version of Studio are you using? It might be better to use the newest feature under Library projects. See here for an example blog:

And the docs for even more info:

Im using 2018.4.5 and “Soap Request” activity from UiPath.Web.Activities package.