New Package SharePoint Activity

Hi Radu @radu_bucur,
We have a problem regarding the Activity ‘Upload Large File’, the problem is after using the ‘Upload Large File’ then we download the data again using the activity ‘Download file’, then the file we downloaded is corrupt when we open it.
Example :

  1. Using Activity ‘Upload Large File’ for file ‘X’  Success
  2. After upload, for the next day, our program will download the file (File X).
  3. Next day : Using Activity ‘Download file’ for file X  Download Success
  4. But, The file is corrupt when we open it.
    Please help, why this case happened, and what’s the troubleshoot ?
    Thank you before for your help & support

Hi,

Just to troubleshoot, could you try to open the corrupt file with a file editor. Can you check the first few lines of the file? and paste them in here. (It’s even easier is you do the test with a txt file)

Hi @diahrismayanti18,

Which version you are using for this package? 1.7.0 or 1.5.2?

Have you tried running your process with another version of this package? Does it run fine with another version?

Regards
Sonali

Could you attach a sample, it’s very hard to go by only on the information provided so far

Hi @diahrismayanti18,

The performance of that package is slow and when your robot has to run thousands of times, it will soon add up. My advice is you do not use that package at all.

UiPathTeam.SharePoint.Activities

Is not an official UiPath Package. Although the recent version seem to have better documentation than when I last tried it.

I have tried to inform this in different threads:


Instead create a custom PowerShell script which will perform great and you will always know what the code is doing.

Jeevith, for a lot of the activities the queries can be grouped up, so the performance can be improved greatly by that, regarding the file upload/download, that can be a bit slow depending on the file size, but there’s really not much we can do in that scenario, the delays are inherent to the SharePoint back-end, not the activities themselves