New Forms Activity Dictionaries Disabled after latest Update!

Kind attention: @radutzp , @alexandru !

The UiPath Form activities have been paralyzed since the latest UiPath update. Last night I worked on a forms project and then allowed Studio to update overnight. And when I came back to the project this morning, I found that I was locked out of all the dictionaries in the Form activities! :neutral_face:

I’m not sure if my system has an issue and/or requires a complete reboot, but despite updating to the latest *non-preview* packages, and adding new activities to the designer surface, I’m unable to get access to the dictionaries except the Show Form activity where there is a poor workaround. :frowning:

Here is how Show Form looks like.

The Poor Workaround: When I move the Slider to off and back to on, the Dictionary is unlocked!

What?! :open_mouth:

Set Form Values/Get Form Values are completely Unusable!

Completely locked out of dictionaries even if I delete and add brand new activities to the designer!

Collection is accessible when Form is not selected

Collection is Locked as soon as Form is selected :neutral_face:

*Package Stack and Studio Version:

All package versions are set to the latest non-preview versions

Please offer a solution. This Forms application is 90% complete and I need to get this done.
I will reboot my machine to see if it helps, although it does not make logical sense to why I should do that.

thanks,
Andy

1 Like

Confirmed! A complete restart of the system did not help. Situation remains unchanged. :frowning:

@AndyMenon

For now try downgrading the system activities and check if that helps…

Cheers

Well I upgraded to latest versions after the older versions broke following the UiPath update that went through overnight.

Thanks

Hi @AndyMenon ,

Just started checking on the same and I’m a bit curious on how you ended up with the Form Option having the Path Info as well.

main/main_form

Even though I have the Form in the Folder main, it doesn’t show up in the same manner :

I’m using Studio Version 23.4.0 currently.

Well the answer to that is simple.

Each form is within its own subfolder.

I’ve grouped all related trigger files and form-specific .xaml files under each subfolder along with the form file.

In this case that folder setup is:

\main
\main\ main_form
\main\on button1 clicked.xaml
\main\on button2 clicked.xaml

I also discussed why i did this in the latest video I published on my channel. You can check it out for a visual feel of what happens if forms arent organized this way.

16:47, Section 6 of this video:

Thanks and i hope this helps.

P.S. That said, it depends on what your application is.

For example: In my case Im building an application for small businesses that can be run as an Attended automation. It has at least 4 forms and needless to say, I have to organize the forms and their associated files some way.

I’m back on my latptop @supermanPunch .

The path discrepancy on your machine is either:

An error following an update
The package versions for UiAutomation, Forms and System may need to be up or downgraded.

I have always worked this way with forms grouped under folders and seeing your issue for the first time.

thanks,
Andy

Okay, this seems to be a serious problem. Upgrading to the latest 23.5.* packages or downgrading to lower version that were working is also not working!

I moved my project to an entirely new PC that I prepped by installing the latest CE version of UiPath as of this afternoon US EST. Sure enough when the project was opened in the new Studio, all Form activities have been rendered utterly useless. :confused: :-1:

Honestly, if we had the option to not have the updates imposed on us, we could have at least finished our projects before allowing the update to go through. And now everything has come to  standstill!

What a disaster?!

Update: Sunday

This is the standard workaround that can get you past the holdup:

For Show Form activity, you can toggle the “Continue Workflow execution” slider to unlock the dictionary and make updates.

For Set Form values and Get Form Values activities, follow these steps:

  • Click on the activity
  • Go to properties
  • Type an empty string between double quotes “” and tab out of the field
  • You must see the dictionaries unlock
  • Make updates to the dictionary
  • CRITICAL: Go back to the Instance Name and wipe out the empty string to avoid run time failure!:hushed:

  • Save changes to form

This process must be repeated each time you come back to these activities to make changes.

As of now, I’ve run my application successfully, and even added an entirely new form, and I did not see any issues as far as the intended functionality of the application is concerned.

Thanks!

— End Update —

Okay, Something about “Instance Names” came to my mind in a UiPath video I had seen on Forms a few weeks ago. So I came back to the project and gave the Form activities an Instance name.

And the dictionaries got unlocked as soon as the Instance names were put in! :confused:
I was able to access the dictionary items and make changes to the form inputs!

But, here is the catch:

It happens only once. If you save and come back to the file you will see that the dictionary is locked. To unlock it, remove the value in the Instance name and then put it back after you make changes to the dictionary.

Basically you have trigger a value change in the Instance name to unlock the dictionary collections.

This is messy, but it works! I was able to get my application working. Give it a shot on your end to see if this behavior can be reproduced.

The same thing happens when I do this for Set Form Values and Get Form Values activities. Now, this is only for activities that have dictionaries associated with them.

Activities such as Close Form do not have this problem, but I guess that once an instance name is provided to a form when it is launched, then that instance name must be input to all Form actions? Yes? :thinking:

New package stack:

@AndyMenon ,

I guess this is an approved bug :sweat_smile:

After updating my Studio to the latest version now, 23.4.2, I do have the same issue. And all the methods you mentioned as a work around does work.

You could see that the Arguments Property is Locked in the below image and also the form Path is updated as well :
image

But again this happened only after I updated my Studio.

2 Likes

Hey @supermanPunch ,

Thanks for confirming the situation!

Let’s hope UiPath has a fix for this bug.

Hoping other members of the community using forms will vote this topic to get it on the priority list.

Best of luck to us.
Andy

2 Likes

Update: Confirmed. After latest Studio update there is a new Components tab that shows up when a form is opened for edit.

This is really convenient and allows more space on form designer.

But make sure to keep all the windows on the left pinned. Otherwise it will be easily missed. :sweat_smile:

@supermanPunch , some more news for you with the 2023.6 update!

The components menu in the forms designer has gone missing! :fearful:

I see that the activities tab has been renamed to components. Has the forms components moved in there by any chance?

ThanksIII

we still have this issue, version 2023.10, any news on that?