New Ask/Inquiry for: Pending Allocation - Modern Folder Unattended Floating Robot post

Hi everyone,

The situation I’m trying to fix now it has already been posted in a couple of articles which are already closed so I was advised to open a new one and tag those articles if I still had a question or reply so here it is:

I’m still getting a ‘Pending allocation’ under the ‘User’ column and ‘Manual’ under Source colum on the Jobs tab in Orchestrator even dough my robot is ‘Unattended’.

•I wish I could ask @codemonkee what he did to get it fixed?, but the interaction is closed! I mean, as soon as I got Orchestrator to show only ‘Unattended Floating’ the UiPath assistant stopped showing the processes on my ‘modern folder’ of course and states ‘Robot does not exist’.
•How to get a ‘Unattended’ robot under Modern Folder if they are Dynamically allocated at the time you run the process?

Theses are the article I’m referring to:

@loginerror has a good point on the article below and I agree, good reference:

"Orchestrator does not support scheduling robots on attended robots. License-wise, attended robots are meant to run processes manually with the user himself starting them. "

Be Safe!

My ears were burning!

In my specific scenario I was testing with incompatible Robot Versions (19.10.4) with the version of the Community/Cloud Orchestrator that was released at the time. As I am an enterprise customer I was trying to shy away from mixing the EXE and MSI packages on a single host (as running multiple versions is not supported) At the time you could only download the Community EXE version.

@badita was kind enough to provide an early build of the 20.x MSI for me to test out.

Not sure if I’ll have the time I’ll try and test it out again in the near future, as we still running 19.10.x for Studio/Robot/Orchestrator so I would end up having to uninstall and reinstall Robot on a machine.

I would suggest providing as much information as you can about your setup and the steps that you have already gone through, the more information you can provide will be easier for other to help you diagnose the challenge with you.

I think the details I provided in my post would be sufficient to get an idea.

  • Robot Version
  • Orchestrator Version and Edition (Community/Cloud or Private Enterprise)
  • Details about your Machines, Users, Robot, Folder setup
  • Status Message from the UiRobot (Hover over the status for sub-details)

Cheers,
Tim

1 Like

Thanks for your response @codemonkee,

In general I will say I do have my ‘Modern Folder’ showing my processes and everything works in general terms. The thing is, since I still have that ‘Pending allocation’ for running a process automatically I thought, let’s take another look if there is new info on the forum and then I saw your post.

Let me see what info can I share to answer to my best knowledge since not sure about all of them:
• Robot Version: must have been uipathstudiosetup.exe ( usually use file as .exe)
-How can you tell which version is install without knowing if you used .exe or .msi?
• Orchestrator Version and Edition (Community/Cloud or Private Enterprise):
Just about to ask where to find it but found this:

image

• Details about your Machines, Users and Folder setup:
Machine:

Users: Basically the 2 you get by Default

Folder setup: I use Modern Folder, see below

• Status Message from the UiRobot
I Hover over the Status at the Robots tab and got this:


The green one autogenerated is coming from here:
image

For the purpose of this post I set it back to Inherit from user’s group. Sometimes I usually set it on ‘Attended’ or ‘Studio’.

I think this is the actual part where I’m not selecting the best option!

Well, I hope these details might help to get another perspective, thank you!

I haven’t really looked at 2020 yet, but I recreated a Community Tenant at first glance it looks like you might not have provisioned an Unattended Robot for your user, only an Attended type robot (in your last screenshot).

My local robot is connected with an Unattended and StudioPro license and I can successfully trigger a Job for both Unattended and Studio.

However If I remove the Unattended Robot from my user and try to trigger a Job type Unattended with no other Unattended Robots available in the folder the following error is produced

Couldn’t find any user with unattended robot permissions in the current folder. (#1671)

My guess is that it sees your Bot\Unattended Robot so it lets you trigger a job, but as the Robot is unavailable the job stays in a pending status.

With this I am referring to the UiRobot Tray / Agent Desktop, I think in this version it has been rebranded “UiPath Assistant” on your host machine. If you hover over the Status it displays more information can sometime be helpful in troubleshooting if it wasn’t licensing correctly.

image

It also shows you the version of the Robot, but this is also displayed in your Machine view of Orchestrator that you posted as it had connected.

1 Like

Hi @MARIODC

Some quick checks. Is your Machine template attached to your Modern folder here:

As far as licenses, I think you have to setup your user for the Unatteded Robots.

In short:

  • have a robot user with unattended config set (just go to point 3 and fill things in)
  • have a machine template with 1 unattended runtime
  • attach the machine template to the modern folder

Now, when you start a process, it should go like this:

  • Orchestrator wants to run a process
  • it checks your Modern folder and sees that you have a machine template with 1 unattended runtime
  • it checks if the folder has any users who can consume that runtime -> it now does, as your user has the unattended configuration in it
  • it starts the process

I seriously hope I got this right, otherwise it will be embarrassing :sweat_smile:. In case I didn’t though, we’ll figure it out together :smiley:

2 Likes

Thank you @loginerror,

I’ve check the first 3 bullet points you have suggested and they are as you indicate, let me share some screen shots then:

  • have a robot user with unattended config set (just go to point 3 and fill things in)
    -Bot name is: Bot\unattended - checked!

  • have a machine template with 1 unattended runtime
    -Machine name is: ModernMachine -checked!

  • attach the machine template to the modern folder
    -Machine template is attached to the Modern Folder -checked!

This is how is been on daily basis but still not getting the job allocate the Unattended bot by itself.

I agree with you and @codemonkee is all about having that ‘Unattended’ bot recognized can’t really get to that point jeje!

I like the path you described about the process starting and looking for the bot, great info!

Thank you!

And does Bot\unattended match the intended Domain\User or machinename\User that is connected with the Robot client?

2 Likes

I will check and get back to you!

Eureka, thank GOD! it worked my friend!

I was just typing (you can see the update jeje) there was no changed but in fact it did. It was processing all ‘previous processes’. I changed the Bot\Unattended to my PC ‘Domain\user’ and that was the difference, thx so much for the suggestion @codemonkee!

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.