.NETCore / .NET5 package support?

I am trying to add packages to a project that target .NET Core or .NET 5, but they always fail because UiPath is redirecting the target to .NETFramework,v4.6.1.

Is .NETFramework the only supported version of .NET, or is there some prerequisite setup I need to do to enable .NETCore/.NET50?

Hello @cdenney!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly

Hi @cdenney,
Actually the Studio is indeed refering to .Net 4.6. but we have an update to newer version on the roadmap. Stay tuned! :slight_smile:

1 Like

Hello any news on the update to support .Net 4.7.x or greater?

Hi @Morten_Riis_Larsen,
Have you checked already our newest release?

1 Like

Yes I have tried it, but gets the same error an extension may not be on a greater version of .net 4.6.1

Hi @Morten_Riis_Larsen

Could you maybe elaborate on what are you trying to achieve?

Hello again

I’m trying to build an extension where I use a component witch requiers .Net 4.6.2 or above.

The extension template has locked the .Net version to 4.6.1 and if I manuly change it to 4.6.2 the studio will not see it or install it refering to version 4.6.1 to work.

Hi @Morten_Riis_Larsen

As mentioned above, latest Studio versions should accept packages built for .NET 5. In fact, we are currently migrating the existing packages for them to be supported by the new framework.

As such, if you build your custom activity on .NET 5, you will be able to use it with .NET 5 projects in Studio.

However, the template has not been maintained and I cannot promise any deadline on when it will be updated to .NET 5.

1 Like