Need to click a drop down panel in GUI Desktop application

I have got a desktop application named - EXCERPT, i have to click on "Data " option from the tool bar menu , in debug mode, i checked with highlight element it is able to identify that element and selector passed without error, but the drop down didn’t appear. i have tried with simulate and window messages both didnt work, i tried with hotkeys it is also getting the same result, when i tried with click text activity , i was able to bring that drop down, but from yesterday again im facing the same error.

using manual mouse i am able to bring that drop down.

Please help me out @ppr @Rahul_Unnikrishnan @Palaniyappan


please find the selector as well

Can you increase the Delay Before, Delay After and check?

Did you try with Hardware click? With a desktop application, Simulate and Send Window messages might not work.

Hi @muhamed.fasil1

If it’s silverlight based applied then enable silverlight and Java extensions.

Also have you tried in debug mode, step-into (enable the highlight element as well)

Plz share how it is responding.

Let’s first change few properties of that click
Enable simulate click
Use wait for ready as None

Surround that click activity inside action block in RETRT SCOPE activity and in condition block use a ELEMENT EXISTS activity that looks for an element after drop down
Have number of retries as 3 or 5
Try on this way and let us know

Cheers @muhamed.fasil1

@Palaniyappan ,

i have enabled simulate,
tried with window message,
tried using wait for ready as none & complete
retry scope is also given. but the result remains same

Hmm try with hot keys or Computer vision activities here


tried debugging enabling highlight activity, and it is getting highlighted and even the activity is executed successfully

you mean default click?


Yes. On Desktop applications, it’s most often the only supported Input Method type.

@efelantti Default click method is also not working

How is it not working? Do you get an error message?

@efelantti no the activity passes on run, but the action is not happening, enabled the highlight in debug mode, it is able to highlight the right selector while running

Could you try to isolate the issue? Create new workflow just containing the click activity (and scope, if you use Modern design experience) and see what happens.

Apps like this usually accept keyboard commands, and that’s a simpler way to navigate menus.

@postwick could you please brief?

I’m not sure what you mean. Keyboard commands are a pretty standard thing. Most apps support them. In UiPath you use the Keyboard Shortcuts activity to send them. In your app, it could be something like Alt+D to open the Data menu.