Need help with triggering UIPath Robot in a docker container

Hi,

I created docker image using below instructions

FROM GitHub - microsoft/containerregistry: Microsoft Container Registry description and related FAQ

ADD https://download.uipath.com/UiPathStudio.msi C:\temp\UiPathStudio.msi

*RUN PowerShell -Command New-Item -Path “C:\” -ItemType “directory” -Name “UiPath”; *

** Start-Process C:\temp\UiPathStudio.msi -ArgumentList ‘ADDLOCAL=DesktopFeature,Robot,Studio APPLICATIONFOLDER=C:\UiPath /quiet’ -Wait; **

ADD / c:\temp\*

CMD [“cmd”]

After creating docker image I ran the docker container using below command

docker run --network “Default Switch” -it testdockerrobot cmd

After this step command prompt opened inside the container and I ran the below command inside the container

uirobot.exe -f “c:\temp\Main.xaml”

Main.Xaml contains only Writeline.

When I run above command UIrobot.exe is throwing "error occurred " message. There is no log and no information available about the underlying error. Can someone please help me to resolve the issue?

Is anyone ran the Robot inside the container? If yes, Am I following the correct steps to trigger the robot?

I don’t believe you can run UiPath Robot inside a Windows container. The Windows containers are all command line only and don’t have a desktop GUI.