Need help in Advance Training- Practical of UiDemo

Can anyone please help me in solving this? I am stuck with login piece here. Previously the credentials which I set in Asset were different but now I have changed them as given in academy but I am not sure why is it still considering the old credentials.

UiDemoLogin.xaml (8.7 KB)

Thanks in advance :slightly_smiling_face:

Hi @sgshreya95

I wonder whether it’s taking the credentials from the windows credential manager. Could you do a quick search for windows credential manager in start menu and see whether you have a recent credential for this there? If it has, delete that and try again to see whether it works…

Hi @Lahiru.Fernando

Yes, it was taking credentials from windows credential manager. As you mentioned, I have removed those credentials and ran the workflow again but the credential manager is again asking to provide credentials there.

Can you please keep me in the know how come this credential manager came into the picture?


Hi @sgshreya95

It comes into the picture through the get credentials xaml file. If you open and look closely, it first tries to get the credentials from the orchestrator. If that doesnt work, then it tries to get the credentials from the windows credential manager. So if windows does not have the credentials it will prompt you that screen to obtain the credentials for the first time. Next time onwards, it will use it whenever orchestrator credential is not accessible or not present. This must have come into the picture while you were developing it you must have got the same screen previously and you must have inserted it. :grinning:

The reason for it to fail to get orchestrator credential is what we should investigate. In the get credentials workflow for get orchestrator credential, we have to get the credentials asset name that comes from the config. When invoking this workflow we pass the credential asset name as a input argument as in_credential. Make sure you are passing the proper name for this. It looks like this is the point that’s going wrong… :grinning:


Thanks @Lahiru.Fernando

It is working fine now. :slight_smile:

1 Like

Moving forward, now I am hitting error while running InitAllApplication workflow.


(upload://6HqhhwJhOySVZGxGyOvG0dm9cbF.xaml) (6.5 KB)

Thanks in advance.

Cool @sgshreya95

Glad to know it’s working for you.

If my answers helped, please also mark the appropriate answer as the solution too :slight_smile:

Thank you!!!

Happy automating

Hey just saw this post… I dont have a laptop right now to check your code. So could you please share some screenshots of your workflow along with the error you are getting

Here is the snapshot of error.


Hmmm… seems like it’s getting a null value from some point. This could be the file path that you are taking from the in_cofig.

Check whether that key is same as the name mentioned in the config. Also, check whether there is a value for that key in the config. Basically in the config file you should have the full file path mentioned.


I am still not able to figure out where I went wrong. Can you please look into it and suggest me?

Config.xlsx (19.3 KB)

I did the same as mnetioned in the PDF given at Academy.


InitAllApplications.xaml (6.5 KB)

Hi, try putting it in the settings sheet as under name and value. Then invoking it.

Yes, that is what I did :frowning:

still no hopes?

@sgshreya95 Refer my (1.1 MB)

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.