Native Text not Fully Reading Unattended


#1

Scenario: Running automation unattended from Orchestrator returns different values when reading element with Get Native Text

Steps to reproduce: Run automation from Orchestrator (bot is on an Azure VM)

Current Behavior: Fully read spied element

Expected Behavior: Reading only half of element

Studio/Robot/Orchestrator Version: 2017.1.6547

Last stable behavior:
Last stable version:
OS Version: Win 10
Others if Relevant: (workflow, logs, .net version, service pack, etc):

Element isn’t fully read with Get Native Text. Cannot use Get Full Text, as I need to read a dynamic Adobe PDF with dropdowns. Get Full Text will return each item of the dropdown, not showing the selected item.

Automation cannot read the element spied. The window is maximized and activated before reading, however only half of the element is returned


#2

Have you tried any other OCR engine?


#3

@jcc608

Is the partial Get Native Text returning a string unique enough that you can compare it to the Get Full Text array and determine the complete item?


#4

Sorry for the late response guys. Was able to figure it out, looks like the VM when running unattended runs a different resolution. Zooming out on the PDF (100->65%) after opening it, then reading the text worked