MV3 browser extensions are broken when starting Edge v115 with InPrivate option

Hi @Balint.Kulcsar,

This is a Microsoft Edge bug that affects all MV3 extensions and we have reported it to Microsoft. We cannot build a patch to fix this issue, we will have to wait for it to be fixed in a future version of Edge.

From UiPath end, we can only provide the above workarounds for now. Please try to apply one of the workarounds that best suits your case.

Thank you,
Luiza

Hi Bailint, have you opened a ticket with support directly?

Hey @Luiza_Surdu-Bob ,

Any Updates on this issue?

Regards,

Hello, all our automations are using InPrivate mode for Edge interactions so massive impact in our side . Please provide update as soon as issue is solved.

I tried to install UiPath MV2 extension by adding the extensionID to the ExtensionInstallForceList but i canno’t check allow in private because it doesn’t show extension after changing this.

Last manual workaround is to launch robots manually and when edge is opened in InPrivate, i launch edge again to launch the “ChromeNativeMessagingHost.exe” and then it can work. This is a very short term workaround because we have more than 40 running.

Best regards

Hey @Jithesh_R ,

Unfortunately we have no updates. We have received a confirmation from Microsoft that the case has been registered, along with a TrackingID, but it is still under review.

We will ask about the status and update this post as soon as we have news.

Thanks for your understanding.

Best regards,
Luiza

1 Like

Hello @Matt67 ,

We are sorry for any inconvenience this issue may have caused. Unfortunately we have no updates, but we will write here when we have news.

I understand you have tried to install the UiPath MV2 extension, but it didn’t work.
Please make sure you have added the correct value to the ExtensionInstallForcelist policy (corresponding to the Group Policy Online installation):
bhchaenngmlcobfechfkikaofjlmejop;https://edge.microsoft.com/extensionwebstorebase/v1/crx

After this change, you can restart the browser and you should be able to see this extension and set the “Allow in InPrivate” option for it.

We have tested this solution and other customers also have confirmed that it worked for them.

Please do another test an let us know the result.

Thanks and best regards,
Luiza

Hello,

it works fine, thanks for explanations, now we can wait the fix from Microsoft!

Have a nice day

Hello everyone,

I’ve just got this new version : 115.0.1901.200
issue is still there

Hello @Matt67 !

I’ve tested now Edge 115.0.1901.200 and the issue is still present.
I’m actively pushing the Microsoft Support Team to escalate and fix this issue, and we will post an update here when it is resolved.

If you’re not seeing this for Edge InPrivate mode then you probably have a normal Edge browser window open.

1 Like

I’ve just updated my previous post, i’ve tested while having an Edge already opened not in incognito… also still waiting for the fix…

Sorry for misunderstanding

We also facing to this issue… and we have tried this solution. It’s working well. Process are running on a isolated VM so, we can wait a little bit in v114.

Hi @Luiza_Surdu-Bob

I am also facing the same issue. But I have observed is when I updated the UiPath Studio/Edge extension to 2023.4 then only I started getting an InPrivate mode “Can not communicate with the browser” error.

So, I Uninstalled UiPath studio and extension and reinstall 2021.10 with the same version extension, and It started working.

(NOTE: Edge Version 115. 0.1901.203 (Official Build) (64-bit))

My Question here is, If I install 2023.4 studio and keep the 2021.10 edge extension will it work, or is it good practice to keep the studio version higher and the extension version lower??

Please suggest as we have planned for the upgrade to latest version from this month.

1 Like

Hello, any news regarding this issue ?

Thanks a lot

Hi all,
we are trying to implement workaround #3. Edge group policy has been updated to bhchaenngmlcobfechfkikaofjlmejop
But the extension is not installed even after restart of the computer.
What shout we do to get the extension installed?
Thanks for any guidance!

1 Like

Hi @prashantP ,

After you updated Studio to version 2023.4, the MV3 extension for Edge was installed. You started getting the error for starting browser with InPrivate option because it only appears for MV3 extensions.

When you reverted to Studio version 2021.10, you probably used an installer with a version lower than 2021.10.8, which installs the MV2 extension for Edge.

You can install Studio 2023.4 and use the MV2 extension for Edge until this issue is resolved. For workaround #3 we recommended the installation of the extension with the ID bhchaenngmlcobfechfkikaofjlmejop, which is the latest version of the MV2 UiPath extension for Edge.

The best practice is to use the browser extension that comes with the latest version of Studio. But for specific cases like this, you may need to use lower version of the extension.

Regards,
Luiza

Hi @Jambor_Attila ,

Maybe the additional explanations in this answer could help:

Regards,
Luiza

Thanks for reply @Luiza_Surdu-Bob

I tried to install Studio 2023.4 and uncheck the extension for Edge by navigating to the advanced setting option to keep a lower version extension(i.e. v2021.10) as it is but it is removing the existing Edge extension(i.e. V2021.10) from the browser.

so I tried to search for the extension UiPath Browser Automation 21.10 but I am unable to find it.

so, my question here is, Is there any way to install an extension (UiPath Browser Automation 21.10) or can you provide steps on how to download and install UiPath Browser Automation 21.10

Thanks,
Prashant.

Hi @prashantP ,

I don’t know if you have seen the update from August 30th, in the original post, regarding the workaround implemented with UiPath.UIAutomation.Activities package version 23.8.0-preview. If you use this package dependency in your projects, you can continue working with the MV3 Edge extension version 23.4.

But if you still have other projects using lower versions of the UIAutomation package, and you want to use the MV2 extension, it is not enough to install the extension directly from the web store. You also need to ensure the native part of the extension (ChromeNativeMessaging.exe) is configured correctly. That’s why it is recommended to install the extension from UiPath Studio.

In this case, you can use these steps:

  1. Install Studio 23.4 and the Edge extension 23.4 (from the installer, or from Studio after installation).

  2. Install the MV2 extension by adding the bhchaenngmlcobfechfkikaofjlmejop extension ID of the 22.4 Edge extension (MV2) to the ExtensionInstallForcelist Group Policy, like this:
    bhchaenngmlcobfechfkikaofjlmejop;https://edge.microsoft.com/extensionwebstorebase/v1/crx

If you installed the 23.4 MV3 extension using the Group Policy Offline installation method, you can also keep the ID of the 23.4 MV3 extension in the ExtensionInstallForcelist and just add another String value for the 24.4 MV2 extension. Either method should work.

  1. Open Edge browser, go to the added extension: edge://extensions/?id=bhchaenngmlcobfechfkikaofjlmejop and enable “Allow in InPrivate” option (and “Allow access to file URLs” if needed).

Please let me know if it works.

Kind regards,
Luiza

Hello, any update to provide ?

Thanks

Hello @Matt67 ,

Unfortunately we have no meaningful updates.
We’ve received confirmation from Microsoft that they are going to fix this bug, but no estimate for when that is going to happen.

1 Like