MV3 browser extensions are broken when starting Edge v115 with InPrivate option

The latest Microsoft Edge browser update to version 115.0.1901.183 introduced a bug regarding the initialization of MV3 extensions for Edge started “InPrivate” mode.

This issue affects all MV3 extensions, not just the UiPath Extension for Microsoft Edge.

We have reported this issue to Microsoft as an Edge bug and are waiting for their review.

Observed behavior

When Microsoft Edge browser is started using:

  • the Open Browser activity with Options → Private property set to True or
  • the Use Application/Browser activity with Options-Browser → Incognito/private window property set to True

The browser is opened, but the following error is displayed: “Cannot communicate with the browser, please check the UiPath extension.”

The extension is initialized correctly when a normal Edge tab is opened (the Private option is set to False).

Available workarounds

  1. Open a normal Edge browser tab before launching the “InPrivate” browser tab.

    Disadvantage: requires changes to the automation projects

  2. Use a temp custom user data folder for the “Open Browser” activity instead of the “InPrivate” option.

    This achieves the same effect - cookies can be cleared by deleting the custom user data folder.

    Disadvantage: requires changes to the automation projects

  3. Install the UiPath MV2 extension.

    This can be done easily by adding the bhchaenngmlcobfechfkikaofjlmejop extension ID to the ExtensionInstallForcelist Group Policy.

    Advantage: no changes are required to the automation projects

    Disadvantage: users will need to manually re-check the option to “Allow in InPrivate” from edge://extensions/?id=bhchaenngmlcobfechfkikaofjlmejop

  4. Downgrade Edge to v114

    See instructions here: Microsoft Edge rollback for enterprises

:bell: Update August 30, 2023

As we mentioned before, this bug was reported to Microsoft, but is not yet fixed in Edge v116, v117 or v118, and we do not have an estimated time for resolution. Until this issue is resolved, we have implemented workaround #1 from the list above in v23.8-preview of the UIAutomation package.

If you decide to use this solution, for the affected projects you just need to update the UiPath.UIAutomation.Activities package to version 23.8.0-preview, which is available in the official feed.

The workaround will also be provided in the next enterprise version v23.10 of the UIAutomation package. However, since this is an Edge bug that affects all MV3 extensions, we are still waiting for it to be fixed in a future version of Edge.

:tada: Update November 3, 2023

Microsoft notified us that the original bug was fixed in Edge v119 and our internal testing confirmed this as well.

As of November 2nd, Edge version 119 is on the Stable Channel and the progressive rollout has started. Therefore, once your browser is updated to this version, you will no longer need to use the workarounds.


Do we have any update on this? Our client’s robots broke with the 115 release and having this again after the 114 chrome release last month is just not ideal… it doesn’t make the software look good.

Hi @Balint.Kulcsar,

This is a Microsoft Edge bug that affects all MV3 extensions and we have reported it to Microsoft. We cannot build a patch to fix this issue, we will have to wait for it to be fixed in a future version of Edge.

From UiPath end, we can only provide the above workarounds for now. Please try to apply one of the workarounds that best suits your case.

Thank you,

Hi Bailint, have you opened a ticket with support directly?

Hey @Luiza_Surdu-Bob ,

Any Updates on this issue?


Hello, all our automations are using InPrivate mode for Edge interactions so massive impact in our side . Please provide update as soon as issue is solved.

I tried to install UiPath MV2 extension by adding the extensionID to the ExtensionInstallForceList but i canno’t check allow in private because it doesn’t show extension after changing this.

Last manual workaround is to launch robots manually and when edge is opened in InPrivate, i launch edge again to launch the “ChromeNativeMessagingHost.exe” and then it can work. This is a very short term workaround because we have more than 40 running.

Best regards

Hey @Jithesh_R ,

Unfortunately we have no updates. We have received a confirmation from Microsoft that the case has been registered, along with a TrackingID, but it is still under review.

We will ask about the status and update this post as soon as we have news.

Thanks for your understanding.

Best regards,

1 Like

Hello @Matt67 ,

We are sorry for any inconvenience this issue may have caused. Unfortunately we have no updates, but we will write here when we have news.

I understand you have tried to install the UiPath MV2 extension, but it didn’t work.
Please make sure you have added the correct value to the ExtensionInstallForcelist policy (corresponding to the Group Policy Online installation):

After this change, you can restart the browser and you should be able to see this extension and set the “Allow in InPrivate” option for it.

We have tested this solution and other customers also have confirmed that it worked for them.

Please do another test an let us know the result.

Thanks and best regards,


it works fine, thanks for explanations, now we can wait the fix from Microsoft!

Have a nice day

Hello everyone,

I’ve just got this new version : 115.0.1901.200
issue is still there

Hello @Matt67 !

I’ve tested now Edge 115.0.1901.200 and the issue is still present.
I’m actively pushing the Microsoft Support Team to escalate and fix this issue, and we will post an update here when it is resolved.

If you’re not seeing this for Edge InPrivate mode then you probably have a normal Edge browser window open.

1 Like

I’ve just updated my previous post, i’ve tested while having an Edge already opened not in incognito… also still waiting for the fix…

Sorry for misunderstanding

We also facing to this issue… and we have tried this solution. It’s working well. Process are running on a isolated VM so, we can wait a little bit in v114.

Hi @Luiza_Surdu-Bob

I am also facing the same issue. But I have observed is when I updated the UiPath Studio/Edge extension to 2023.4 then only I started getting an InPrivate mode “Can not communicate with the browser” error.

So, I Uninstalled UiPath studio and extension and reinstall 2021.10 with the same version extension, and It started working.

(NOTE: Edge Version 115. 0.1901.203 (Official Build) (64-bit))

My Question here is, If I install 2023.4 studio and keep the 2021.10 edge extension will it work, or is it good practice to keep the studio version higher and the extension version lower??

Please suggest as we have planned for the upgrade to latest version from this month.

1 Like

Hello, any news regarding this issue ?

Thanks a lot

Hi all,
we are trying to implement workaround #3. Edge group policy has been updated to bhchaenngmlcobfechfkikaofjlmejop
But the extension is not installed even after restart of the computer.
What shout we do to get the extension installed?
Thanks for any guidance!

1 Like

Hi @prashantP ,

After you updated Studio to version 2023.4, the MV3 extension for Edge was installed. You started getting the error for starting browser with InPrivate option because it only appears for MV3 extensions.

When you reverted to Studio version 2021.10, you probably used an installer with a version lower than 2021.10.8, which installs the MV2 extension for Edge.

You can install Studio 2023.4 and use the MV2 extension for Edge until this issue is resolved. For workaround #3 we recommended the installation of the extension with the ID bhchaenngmlcobfechfkikaofjlmejop, which is the latest version of the MV2 UiPath extension for Edge.

The best practice is to use the browser extension that comes with the latest version of Studio. But for specific cases like this, you may need to use lower version of the extension.


Hi @Jambor_Attila ,

Maybe the additional explanations in this answer could help:


Thanks for reply @Luiza_Surdu-Bob

I tried to install Studio 2023.4 and uncheck the extension for Edge by navigating to the advanced setting option to keep a lower version extension(i.e. v2021.10) as it is but it is removing the existing Edge extension(i.e. V2021.10) from the browser.

so I tried to search for the extension UiPath Browser Automation 21.10 but I am unable to find it.

so, my question here is, Is there any way to install an extension (UiPath Browser Automation 21.10) or can you provide steps on how to download and install UiPath Browser Automation 21.10