mustRestoreAllDependencies in json file should set as true or false?


There are few package publish to the orchestrator to be run. All the workflow use the same flow and dependency.

However, there are few facing error when I run through the orchestrator. The errors is “unable to install packages” and the description is cannot find rest sharp.
But, my workflow did not need to use the rest sharp…
(and the process that run successful also didn’t use/install the rest sharp)

Is it possible that it’s because of the


in the json file.
Because I notice the “mustRestoreAllDependencies” in those successful run is false but those fail is true.

Thank you.

Hi @g_ii

It’s possible.
Runtime Option: mustRestoreAllDependencies will force the robot to install all the packages before it runs. If in the case that package cannot be installed, the robot will not run.

Even though the workflow didn’t use the dependency(and I also didn’t install it at the manage packages there), the “mustRestoreAllDependencies” will still force the robot to install??


Dependencies are nested(I don’t think nested is a good word, maybe inherited?), so it might be that one of the dependencies you use is using that “rest sharp” dependency. Take a look at the screenshot below for the reference:

For example UiPath.PDF.Activities is dependent on UiPath.DocumentUnderstanding.Digitizer, which is again dependent on NTextCat.

I checked the dependencies area, there is no any dependency that use the rest sharp.

Can you share the screenshot of your project.json files “dependencies”?

The below is the dependency of my workflow:
“UiPath.Excel.Activities”: “[2.11.4]”,
“UiPath.Mail.Activities”: “[1.12.3]”,
“UiPath.System.Activities”: “[21.10.4]”,
“UiPath.UIAutomation.Activities”: “[21.10.5]”

Yeah, I have confirmed that. I tried to find that dependency somehow but had no luck.

If one of your packages is dependet on RestSharp it will probably be

UiPath.Mail.Activities”: “[1.12.3]”

although I couldn’t find that dependency.

Do you use mail activities in the project? If not, could you remove it and try then? Tbh I’m really curious about it.

Ya, I did use the mail activity in the process.

And I also manually install the rest sharp.

And after all this is done, the orchestrator is able to install the packages ald.

And thanks for your help.

1 Like

And the conclusion is that the “mustRestoreAllDependencies” didn’t cause it unable to install packages.

The issue is caused by the rest sharp

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.