Multiple Assign Activity not Working

From Studio version 2020.10.0-beta.1008
when using multiple assign, the tool seems not to work properly, if you look a the picture, the variable is assigned but still error is present, if you take a close look, you will notice the the assignment is not happening (if opening the expression editor, you notice it’s empty)

I have the same issue, this also goes for other activities. For now it works to just fill it into the Expression Editor directly. Hope there will be a real solution fast!

1 Like


i am using stable version of studio, i don’t see any issue with multi assign activity




Do you geht an error with SHIFT + F7 when you try to analyze the project ?

@mario.guadarrama I faced similar issues with a lot of assignments under multiple assign. The values disappears and also duplicate ones will form when i do “Collapse All” and "Expand All’ workflows. Any help is appreciated!

1 Like

I have seen the same error on 19.10. Dont know if is currently happening on 20.4 20.10

This happens when theres a major loading of activities in a single workflow e.g. collapsing and expanding all activities will result in the variable names vanishing. Sometimes, even the variables become duplicates. Studio Version i’m using is 20.4. Any UiPath devs interested to fix this error? :smiley:


Yes, after analyzing the process there are no errors

I believe this is now fixed (or will be soon) :slight_smile:

Please make sure your activity packages are updated to the latest version.