Multibot throwing error when custom activity is missing. How to make sure custom activity is part of package which is published to orchestrator


I created a process which uses custom activity in it. I published the package to orchestrator and executed the process on 2 bots. It executed successfully on the machine where I created and packaged custom activity but failed on the machine as it was not able to find the custom activity DLL.

Please guide me.

Kindly make sure that custom activity package is there in your either of machines under the folder

if not place that package folder and try once
Cheers @Dinesh_Kumar_Lalchan

Is there no way we can include the DLL in process package so that when we run from orchestrator it automatically gets copied to bot machine

Upload the package into orchestrator library
Then go to package manager in studio and
Set the package feed to be read from orchestrator
Uncheck the local feed option from the package manager
This will solve the issue