MSアクセスの項目に、変数に格納した値を設定

MSアクセスの項目に、変数に格納した値を設定したいのですが、エラーでとまってしまいます。どういった点を考慮すればよろしいでしょうか?

%E3%82%AD%E3%83%A3%E3%83%97%E3%83%81%E3%83%A3

2 Likes

@111161

Could you please tell more details about the issue. So that we can check and help you.

What error are you getting here ?

2 Likes

As @lakshman said can you elaborate it ?

トピックをより詳細に説明できますか?

Regards
Balamurugan.S

3 Likes

companynameという変数に、値をいれてます
アクセスで作り込んだ画面の、項目名が会社コードのところに、その値を設定したいので、セレクターで要素を指定しましたが、エラーとなります
レコーディングのクリックでも試しました
会社コードのヘッダーも相対位置指定しましたが、うまくいきません

@111161 さん

こんにちは。

エラーとなります

具体的にどのようなエラーメッセージが出ていますか?

正確なエラーメッセージをお知らせください。

また、セレクターを適切に確認できますか。必ず、idxを使用していないことを確認してください。それでも動作しない場合は、送信ホットキーを使用してみてください。

#HappyRobotics @111161

2 Likes

実行すると、条件が定義されていませんとなります
以下のような設定です
もう少し詳細なエラーは、どちらで確認すればよろしいでしょうか?
%E3%82%AD%E3%83%A3%E3%83%97%E3%83%81%E3%83%A3 %E3%82%AD%E3%83%A3%E3%83%97%E3%83%81%E3%83%A32

1 Like

@111161 さん

最初の画像を見ると、Type IntoのTextにCompanyCode(Int32型?)を入れているようなのですが、その後の記述に「companyname(String型?)という変数に値を入れています」とあります。

変数名はどちらを使用されていますか?

また、セレクターエディターで「修復」をクリックして要素を選択してみてください :slightly_smiling_face:

%E3%82%BB%E3%83%AC%E3%82%AF%E3%82%BF%E3%83%BC%E3%82%A8%E3%83%87%E3%82%A3%E3%82%BF%E3%83%BC

Erinaさん
記載が適切でなくすみません。
どちらもCompanyCodeとなります
ただ、変数を使わず定数”00000”などでも、文字が設定できません。。。
Excelであればセルの位置指定などできると思いますが、ACCESSで作りこんだ画面で苦戦しております

1 Like

@111161 さん

エラーが発生した際、StudioのOutput(出力)パネル には
赤字でどのようなエラーメッセージが書かれていますか?

1 Like

Erinaさん
大変ご返事遅れました。すみません!
すでに解消しました。
具体的には、項目名のフィルターボタンにセレクターをあて、そこから上下左右にターゲットの値を移動させ、セルをクリック⇒文字入力できました。
もう少しいいやり方がありそうですが。。。

1 Like

@111161 さん

開発環境の違いもあるかもしれませんが、私の端末では項目名にセレクターをあてなくても文字が入りました。

でも無事に解決できてよかったです :blush: ご丁寧に返信ありがとうございます :exclamation: