Move Outlook Email Issue

Hi, I am having an issue to move the outlook email to another folder. Sometimes it’s moving and sometimes not. But when see in the Inbox it’s still there but after some time it’s moving. How we are sure the email is moved to the respective folder.
@Palaniyappan kindly reply

yah its due to outlook issue i guess
i have faced this many times, that is after some times it will be getting moved to the folder we have mentioned in the uipath
Cheers @balkishan

1 Like

what we have to mention in the UiPath bro. you know bro once it’s moving the email and the email is not there in the Destination folder nor in the Source(Inbox). So strange where the email goes.
How can I make sure the email is proper moved to the Destination folder.

Hi @balkishan,

I think this issue is coming from the Outlook. Sometimes we face the issue when we move mails manually.

Thanks & Regards,
Apurba

1 Like

Is there any solution for this. If the email is not moved my bot will run from the starting and process the same email. So I want to make sure whether my Email move or not move.

Generally how long does it takes for Outlook to move the Email.

Hi @balkishan,

I think we have to use either Mark AS Read option to avoid re-reading or have to use Delay activity to avoid the slow working of Outlook.

Thanks & Regards,
Apurba

1 Like

Delay is how much delay you want. But after 2-3 min I seen the email is moved. I don’t think the delay is work here. Bcz Bot is already moved the email but the email is still in the Inbox so this issue leading a very serious problem in the production. Which same I am facing. @Palaniyappan

1 Like

no no
no delay…
because it will move for sure
but takes some time thats all
–we need to be concerned only if that mail moved to a folder is going to processed from that folder, or if the mail is not marked as read in the current folder before moving to another folder, so make sure that the mails are marked as read by enabling both the mark as read and only unread mail property in the get outlook mail activity

Cheers @balkishan

1 Like

This is the problem bro, I don’t use Marked As Read, Here I am reading the Single Oldest email only. So I am reading on FIFO basis. I don’t want to marked all the email, bcz my bot schedule again and process again the last FIFO email only. So this is the reason I have not checked the Mark As Read, That’s way I am moving the Oldest email only. Hope you understand. Same issue I have put in the another post already tagged you, Please reply.