Mouse blinking

Hi guys!

I am having this strange issue, when I start my process it works perfectly, but sometimes for some reason the mouse starts to blinking and shaking a little bit. When this happens the mouse moves to the right place but doesn’t click anymore and the TypeInto activity fails to write in the right place as well. While this happens no Application Error is shown by the Studio nor the orchestrator, so the program just keep going. This doesn’t happens all the times and is hard to capture in a video.

I was wondering if anyone is experiencing or have experienced the same problem as me or knwos how to solve this problem. Or know if this problem is because I did something wrong or its some kind of weird bug and I should talk with the Uipath developers?

Thank you guys in advance!! XD

Make sure that you had set the Wait for Ready activity to INTERACTIVE when mouse is needs to be interactive with UI elements and also enable simulate click (input method) for click activities and check.

The mouse blinks usually when the workflow is executing in the background. It is expected. Nothing to worry.

Regards,
Karthik Byggari

2 Likes

Thank you very much, KarthikByggari!

The mouse was already INTERACTIVE so this was not the problem. I’ll try to enable SIMULATE CLICK and see how it works. After that i’ll post here the results.

Thanks again.

1 Like

Hi! I’ve only could test it today because everytime I run the robot I need to show to my client. The good news is: It really stopped blinking. The bad news is: another problem happened.

What is happening now is. The robot is typing into the search field a subscription but when it sotp typing the subscription goes back to the first subscription typed. As an exmple: suppose that the robot have to type the following numbers (1,2,3,4) and search for it. So it starts with 1 and do the search, but when it goes to the other numbers it correctly types it (2,3,4) but when it stops typing the number goes back to 1 everytime and always searchs for the same number (1).

It seems that my client’s system is not entirely compatible with uipath. That’s what i think is the reason this is happening. Do you have other thoughts about it?

Please increase delay between keys for Type Into activity.

  • DelayBetweenKeys - Delay time (in milliseconds) between two keystrokes. The default amount of time is 10 milliseconds. The maximum value is 1000 milliseconds.

The keyboard events might need some delay to write properly into the text fields. If your workflow is too fast then it misses to write some letters.

Hope this is helpful.

Regards,
Karthik Byggari

1 Like

It Didn’t work! Same problem it doesn’t matter how much time do I put. :frowning_face:

Can you check Send Windows Messages in the properties of Type Into activity.
Try with default also only for this activity.

1 Like

Thank you very much, KarthikByggari, you are awesome! It worked. I’ve just tested it here and worked perfectly.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.