Monthly Report Save AS - works in "step into" mode but not when "running"

@WhenCutEsh This did not work either

@ColinCrabtree can you share us the workflow??

@Joysogood - I am not sure what you mean? when I ran it “Step into” It works. See below

@WhenCutEsh…Here you go: System1_CreateYearlyReport.xaml (24.3 KB)

@ColinCrabtree Let me debug your code , can you try one last attempt by giving a delay of 3 seconds in the delaybofore property of the click activity and remove the simulate click option.

it looks good actually but may be we can go for a trial and error method
this looks wierd but sometimes work like we can use a HIGHLIGHT activity before to the Click activity and select that drop down as element with that highlight activity
–so that the bot will try to highlight that element, and if its able to highlight it should be able to click as well

hope this would work
Cheers @ColinCrabtree

@WhenCutEsh … Whoooooo hoooo !!! the delay worked. Why is this needed ?

1 Like

@ColinCrabtree As far as I know The code is being executed before the element is actually around, Try using FindElement follwed by click and remove the Delay, I had the same issue and just referred my workflow and saw where was it going wrong.

@WhenCutEsh - I tried this as well and it work perfectly. I prefer this solution to the one you provided using the delay as it seems more robust and reliable. - Thank you !! :smiley:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.