Mobile automation website test project crashing testing robot

I have created a simple test project to login to a website and navigate the site in chrome on an android emulator. The emulator and appium server both run on a test machine separate from my development machine, but both machines are on the same local network.

The test machine is running UiPath Community version 21.4.4 with a testing licenced robot. My development machine is running Studio Pro 2021.6.0-beta.4514 Community, with an attended robot. Mobile Automation Activities package is v.21.4.3.

The appium version is 1.21 desktop installation. The emulator is running android 11, with chrome version 92.0.4515 and the corresponding chromedriver.

When I run the project from studio on my dev machine pointing at the appium server on the test machine it runs fine. Launching chrome to the website and interacting with the UI has no issues. The project runs to completion.

However, when I run it via the orchestrator to the testing robot on the test machine it gets stuck. After a certain time UI activities (tap, get text, set text, element exists, etc.) will get stuck either before or during execution. It is not specific to an activity or element, I have removed and added different UI activities and targets, altering delays and timeouts as well. The UiPath Executor on the test machine stops responding, the orchestrator job does not fault or timeout and there are no errors in the log on orchestrator or the windows event log. The appium server times out after 5min due to no received instruction. The orchestrator execution has to be cancelled manually, otherwise it runs infinitely. Further, after this happens once, when running again from the orchestrator the first UI activity in the project will trigger the issue consistently. The UiPath assistant on the test machine will have to be completely restarted in order to reach the initial point of failure again. Mobile device activities like get system time work fine, narrowing the issue down to UI activities.

I have tried recreating the project as a non-testing process (not a test case) and switched the robot to unattended on the test machine but I get the exact same behaviour. Leading me to believe there is a problem running mobile web UI automation specifically on a testing or unattended robot.

Any feedback on this would be much appreciated.