ML Skill - Unable to load retry

Hi Team

I created a sentiment analysis ML Package and skill in AI Fabric[AI Centre] tried to use that Skill in UI Path studio. When i click the ML Skill dropdown it says “Unable to load retry” when i click on retry am getting the below error.

Failed to parse Json string {"@odata.context":"

Can some one please help to resolve this issue


Hi @yasmin.m

welcome to forum

You can resolve the issue by connecting to the orchestrator once
[Like first disconnect and connect again] It will work


Nived N
Happy Automation

Hi Nived,

Yes i tried those still the same error. The ML skill in Orchestrator page shows as attended should it be “unattended” is that the reason am getting this error.

Yasmin M

Hi Nived,

One of my friend suggested me to connect with Machine key in the UI path assistant .When i connect via it i get the error connected unlicensed. Can you please help

Did u use the enterprise version @yasmin.m

The version shows as Studio Pro 2021.2.0-beta.44 Enterprise License EXE installer. Is that fine or should i change to any other version

Yes it is fine

One more info when i created the license via the URL cloud.uipath i could see my bot as “Attended” when i connected the orchestrator to UI Path Studio. For other friends of mine it was Unattended is that the issue?

I tried one more option of connecting and now i see this message “Detected attended robot as the license type.Based on the terms&cond it should be used only for running debugging purposes.Editing is restricted”

Still the issue persists .Can you help me to fix it please.

Also facing the same issue :Not able to load Deployed ML Skil

Hi Sandeep,

Which activity are you referring can you please help me with the activity name ML.Activities?

Two checks you can perform…

  1. You have internet enabled while you are working…
  2. Please use complete endpoint link in activity.
  3. Also please ensure you have api key pasted in activity for alternate purposes.

Hope this helps…


Hi Yasmin, My issue was i was using the latest ML activities package 1.1.5 when I downgraded to 1.1.3 version, I no more hit the error.

Thank you so much Sandeep and Nived. Now am able to view the ML Skills. Thanks a lot again

1 Like


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.