ML Skill not getting deployed in AI center

Iam trying to extract data from custom document. I created a ML Package and then created Data Set using Data manager. Created a pipeline for the newly created data set. The pipeline keeps failing. Should we create the ML Skill after the pipeline runs successfully or we have to create it as pipeline is created

@RPADemo_Mail

First you have to complete pipeline traini g then create skill.

Did you provide minimum od 5 samples?

And check if you are pointing to right dataset

Cheers

I have provided 11 sample documents which is of 4 different formats. The sample you are referring does it means I should used 5 different formats? . My pipeline gets failed when I run it. I have used the right data set.

@RPADemo_Mail

For each type its better to have 5 documents…

But first check the pipeline logs to see why it is failing

Cheers

Checked the pipeline logs. It was failing because of selecting a wrong data set folder. Pipeline run is successful now. Thankyou

Pipe line is successful now, getting the below error while deploying ML Skill. Can you please help me resolve this issue…

@RPADemo_Mail

While creating dataset did you select make this evaluation dataset option?

Did you run training or the evaluation pipeline?

We see this error if wrong option is selected.can you recheck once

Cheers

I ran train run

@RPADemo_Mail

Can you check the detailed logs once please

Cheers

This is my ML log from ML skills

@RPADemo_Mail

If you go to skills you will have details logs inside…

Cheers

Im getting the same error as before
Kubernetes operation failed to create deployment Skill. Could you please tell what this Kubernates operation means. I’m not sure which part I’m missing. Mentioned below are the steps I followed

  1. Created a Dataset
  2. Created ML Package
  3. Ran the pipeline, pipeline was successful
  4. Created ML skill

@RPADemo_Mail

Its a container platform…in this context used for ml skill

Cheers

May be this will help: AI Center - ML Skill Failed / Kubernetes operation failed to create deployment - Reboot Your Skills / Automation Starter - UiPath Community Forum

I have followed the exact same step mentioned above. The below are the error logs for my ML skill. Could you please check if you could figure out the reason for ML skill failure. Thanks in advance

2022-12-26 10:11:48,409 - uipath_core.microservice:main:66 - INFO: Starting microservice.py:main
2022-12-26 10:11:48,409 - uipath_core.microservice:main:67 - INFO: Configuration:
2022-12-26 10:11:48,409 - uipath_core.microservice:main:68 - INFO: worker_type: gthread
2022-12-26 10:11:48,409 - uipath_core.microservice:main:69 - INFO: model_init: lazy
2022-12-26 10:11:48,410 - uipath_core.microservice:main:70 - INFO: server_for_gpu: gunicorn
2022-12-26 10:11:48,410 - uipath_core.microservice:main:83 - INFO: Importing du_semistructured
2022-12-26 10:11:48,412 - uipath_core.microservice:main:98 - INFO: REST microservice running on port 5000
2022-12-26 10:11:48,412 - uipath_core.controller:init:83 - INFO: Fair scheduler: enabled
2022-12-26 10:11:51,700 - matplotlib:_get_config_or_cache_dir:500 - WARNING: Matplotlib created a temporary config/cache directory at /tmp/matplotlib-hpe0vxx0 because the default path (/home/aicenter/.config/matplotlib) is not a writable directory; it is highly recommended to set the MPLCONFIGDIR environment variable to a writable directory, in particular to speed up the import of Matplotlib and to better support multiprocessing.
2022-12-26 10:11:52,593 - matplotlib.font_manager:_load_fontmanager:1624 - INFO: generated new fontManager

2022-12-26 10:11:54,355 - ldclient.util:get:118 - INFO: Initializing LaunchDarkly Client 6.9.1
2022-12-26 10:11:54,357 - ldclient.util:_run_main_loop:226 - INFO: Starting event processor
2022-12-26 10:11:54,357 - ldclient.util:run:51 - INFO: Starting StreamingUpdateProcessor connecting to uri: https://stream.launchdarkly.com/all
2022-12-26 10:11:54,358 - ldclient.util:init:110 - INFO: Waiting up to 5 seconds for LaunchDarkly client to initialize…
2022-12-26 10:11:54,381 - ldclient.util:log_backoff_message:81 - ERROR: Streaming connection failed, will attempt to restart
2022-12-26 10:11:54,381 - ldclient.util:log_backoff_message:82 - INFO: Will reconnect after delay of 0.946592s
2022-12-26 10:11:55,354 - ldclient.util:log_backoff_message:81 - ERROR: Streaming connection failed, will attempt to restart
2022-12-26 10:11:55,354 - ldclient.util:log_backoff_message:82 - INFO: Will reconnect after delay of 0.348682s
2022-12-26 10:11:55,748 - ldclient.util:log_backoff_message:81 - ERROR: Streaming connection failed, will attempt to restart
2022-12-26 10:11:55,748 - ldclient.util:log_backoff_message:82 - INFO: Will reconnect after delay of 3.191661s
2022-12-26 10:11:58,968 - ldclient.util:log_backoff_message:81 - ERROR: Streaming connection failed, will attempt to restart
2022-12-26 10:11:58,968 - ldclient.util:log_backoff_message:82 - INFO: Will reconnect after delay of 1.877900s

2022-12-26 10:11:59,359 - ldclient.util:init:116 - WARNING: Initialization timeout exceeded for LaunchDarkly Client or an error occurred. Feature Flags may not yet be available.
2022-12-26 10:11:59,359 - uipath_core.plugin::46 - INFO: Built in restart triggers: [‘RuntimeError: CUDA out of memory.’]
2022-12-26 10:11:59,360 - uipath_core.plugin::47 - INFO: Externally configured restart triggers: None
2022-12-26 10:11:59,360 - uipath_core.plugin::48 - INFO: Built in fail triggers: [‘Anchors should be Tuple[Tuple[int]] because each feature map could potentially have different sizes and aspect ratios.’, ‘CUDA error: uncorrectable ECC error encountered’]
2022-12-26 10:11:59,360 - uipath_core.plugin::49 - INFO: Externally configured fail triggers: None
2022-12-26 10:11:59,360 - uipath_core.plugin:model_load:144 - INFO: Start model initialization…
2022-12-26 10:11:59,362 - root:initialize_package:146 - INFO: Using package type provided by runtime argument with value: du
2022-12-26 10:11:59,362 - root:initialize_package:155 - INFO: Initializing du package options …
2022-12-26 10:11:59,368 - root:initialize_package:160 - INFO: System-Level Configuration:
2022-12-26 10:11:59,368 - root:initialize_package:161 - INFO: ATen/Parallel:
at::get_num_threads() : 2
at::get_num_interop_threads() : 4
OpenMP 201511 (a.k.a. OpenMP 4.5)
omp_get_max_threads() : 2
Intel(R) oneAPI Math Kernel Library Version 2021.4-Product Build 20210904 for Intel(R) 64 architecture applications
mkl_get_max_threads() : 2
Intel(R) MKL-DNN v2.2.3 (Git Hash 7336ca9f055cf1bfa13efb658fe15dc9b41f0740)
std::thread::hardware_concurrency() : 8
Environment variables:
OMP_NUM_THREADS : 2
MKL_NUM_THREADS : [not set]
ATen parallel backend: OpenMP

@supermanPunch - have you seen this before?

@JithinKP , thank you for tagging me in. @RPADemo_Mail , Could you let us know some more details about the ML package and the version that you are using ?

If it is a preview version , could you change it to a stable version and check if that works for you ? For this you would have to redo the Creation of Package and Training Pipeline again.

Let us know what are your findings.

Using 22.10.1.0 version of the document understanding package. Is this a preview version. How to find that?. Could you please help me resolve this issue. Got stuck in this for a quite few days.

Hi @RPADemo_Mail ,

Not sure if this was also the problem few days ago. But today when I tried to deploy an ML Skill, I was not able to do it and the deployment was failing.

When checked in status.uipath.com, it was also mentioned that the Deployment is getting failed in the Europe region. They are already on to fix this issue. Maybe the same is the case for your issue as well.

You can check the status using the below link :

Did you solve this? I am having the same error