Missing leading zeros in excel

Hi team,
after reading csv, i’ve merged the dt with custom datatable, now my problem is: i’ve two string columns, but when i try to write the dt inside an excel file the leading zeros disappear.
I read a lot of posts regarding this but didn’t find solution yet.
How can i manage this scenario?
Thanks in advancce

since you have not shared your workflow so i assume
Either

  1. the column initially is not in Text format
    or
  2. while you are merging the datatable the text format is getting converted to number format

@andreus91 Before writing dt to excel, replace your column value with appended "apostrophe ` " sign.

1 option:

Alternates:

1 Like

Hi! Thanks for the reply.
Maybe i’ve found the solution.
Instead of having the columns in string type, just using write range of system-> workbook instead of write range of excel application scope->write range. These seems to work fine

Hi, While writing the data into excel, concatenate the ’ before the value.

Hi @andreus91

Use the Format cells activity to format the range of cells in required format by this activity.
image

Note - This activity has to be used inside the excel process scope and use excel file activity

Hope it helps!!

Why are you digging up 2 year old posts and commenting on them?