Missing Activities in version 2016.2.6246

Hello @Lavinia ,

I’m trying to go through all the tutorials, and I can’t find Write to csv activity in the new version (even after patch).

Thank you in advance!

For this you need to install UiPath.Excel.Activities from package manager.

1 Like

Hi @Lavinia,

Thank you very much for your answer!

Have a nice day!

The new Community Beta Build is up since Tuesday.
Can someone confirm this issue is not valid anymore?


the activities have been fixed, still a lot of errors when browsing for activity types

also seem to be only stuck with google ocr in the screenscrape click

i find microsoft slightly more accurate.


Do you have MODI (Microsoft Office Document Imaging) Installed on your system?


In Windows 10 MODI comes by default.
Otherwise you need to install it via Microsoft Sharepoint Designer.


I cannot install UiPath.Excel.Activities

And, of course, some examples from training (like Session 4 - exercise 1 - shopping for laptops.xaml) cannot be run (Could not find type ‘WriteRange’ in namespace ‘http://schemas.uipath.com/workflow/activities’. Row: 82, Column: 8).

I am using UiPath Studio Community Version 2016.2.6344.

Im running the community edition (stable: 2016.2.6379) and after the installation i dont have any activities. When i put text in the activity search bar, nothing is showing up

The fix of placing the UiPath.Core.Activities.2016.2.6246.34820.nupkg in USER\AppData\Local\UiPath\app-2016.2.6379.27755\Packages and restarting UIPath doesn’t give a solution.

Also did a reinstall of the community edition which give the same result.

From this point on, i can’t run the community edition on my pc.

i tried it on another computer and there the install went fine. But on the pc that is giving problems, reinstalling won’t help. i dont see the ui automation and events. any solution to this?


I think the version of Core activities that you are using is incorrect. As you mentioned that Uipath studio that you have is 6379.

First , please ensure if you have the Core.activities package present in the C:\Program Files (x86)\UiPath Studio\Packages or not. If you do not have it , ensure you copy the correct version of Core.activity package from your working machine and place in in the folder mentioned above.

Below is the screenshot of the correct version of Core activities.

Next, open UiPath Studio -> Click on Manage Packages -> Go to “Available” -> “Local” and you should see the Core activities available there. Now install the package to use the activities.


Both of your posted links are locked or no longer functioning.

Is there a chance you could update to the most recent community editions? I can access the version linked via uipath.com , however that version doesn’t seem to alleviate the issues.


As the previous poster said, we need a solution for the newest version of the community edition (2016.2.6379.27755), where this bug was apparently re-introduced.

Could you share a copy of the core activities for 6379.27646.nupkg…this seems to be affecting all who updated to the latest edition.

1 Like

Studio 2017.1.6435 solved this issue. From “Manage Packages” I have installed UiPath.Excel.Activities and UiPath.Mail.Activities.

I tried all the solutions give above, but same error for “SendOutLookMail” activity, what is the solution ?

Im missing Filter Data Table in my activities under the Programming>DataTable. Build, Clear, Generate, Merge and Output Data Table are the only activities available. UiPath.Core.Acitivities is properly installed.

Thank you for responding.