Minimize the RDP window while robot operating the website

Hi everyone,

I would like to know is it possible to minimize the RDP windows while the robot is operating the website, but makes the robot working smoothly and correctly?

I searched the following information but it doesn’t work.

or is there any other way to solve this problem since the users not everyone has multiple displays can let one of them to be idle waiting until the robot finishing the execution.

@opas1216 - which version are you referring Enterprise Or Community Edition?

1 Like

I think this is the only way, but i am assuming you dont have the right to do this reg edit on company machine, Take the help of IT people.

1 Like

Hi @GBK

I’m using Enterprise Edition in my development environment.
Also the Robot in the production environment is attended robot which I’m not sure whether it’s the reason affect.

But right now both of my Enterprise edition environment and the attended Robot environment aren’t work when the RDP window minimize.

Hi @sachinbhardwaj

Actually I did those setting in reg changed, but it didn’t work as expect.

I was wondering is it because I was “log off” my Robot machine instead of “sign off”.
But I couldn’t find button in my task manager can let me “sign off”
image
Is that the reason make the reg didn’t work completely even I already edited the setting?

Hi @lakshman

Sorry for the bothering.
I just saw your reply from the blow topic

I would like to know if the robot I use in my production environment is attended robot, whether it will affect or not result in the minimized RDP window won’t work?

@opas1216 -in ENT version → it will work only with Unattended robot - not with attended robot.

@GBK - So here’s two requirements if I want to make thing work:

  1. Enterprise Edition Studio
  2. Unattended Robot
    Is it what you mean?

At this moment, I have Enterpise Edition Studio in my Development Environment.
And it doesn’t work since I only have attended robot in my Development Environment.

Besides, I only have attended robot(Didn’t install Enterprise Edition Studio) in my Production Environment so it can’t work either.

Do I understand correctly?

@opas1216 - why can’t you try PiP option ?

1 Like

I don’t know the solution to keep robot working properly in a remote session (I’m assuming the robot is running in the remote machine, not on the local machine interacting with the RDP) when the window of the RDP session is minimized. I also tried the solution you referred, but the problem is: when the windows is minimized the graphic user interface no longer exists.

However, there is a way shutdown the remote session and keep the graphic user interface (windows).
Whenever you want to close the RDP run this line on the remote machine:

for /f “skip=1 tokens=3” %%s in (‘query user [USER]’) do (
%windir%\System32\tscon.exe %%s /dest:console
)

Replace [USER] by the remote machine user.

Hope this helps.

1 Like

Hi Opas,

Yes it is possible , You can go with Connecting VM approach and its like Jump host. I mean you need another machine, login into that machine and try RDP to your Bot VM through it and initiate the Bot run. But their are some minimum prerequisites you need to follow like below:

System: Windows server 2012 or windows 10\7
RAM: 8 GB
RDP Resolution: 1366 X 768, should be same for both machines
RDP should have clipboard, driver, printer, smart card, etc. (any other physical level device access) disabled
Should have stable internet connection (Recommended 2 M.B/s)
Run the Bot and disconnect the entire RDP session, should not minimize the RDP.

This approach worked for us in attended mode. One important thing is that the Bot VM should not be locked due to inactive session. You can modify settings to “Never” under Sleep settings on machine or can run any unlock scripts to make the VM active all the time. Please anticipate the last step mentioned above.

Thanks
Sandeep Puram

1 Like

@GBK

Hi,
Thank you for your advice.
Thanks for reminding me of this new feature, I didn’t know this before but I’ll definitely give it a try.
But right now I still need to try the solutions above so that the Trial can move on.

Hi @MMira

Thank you for your reply.
I’m not quite understand how to do this, but I’ll research on this hope can give me some lesson learnt.
Besides, could you tell me where to run the instruction on the remote machine?
Is it executed inside RPA or CMD or what tool?

Thank you for your kindness

Hi @Sandeep_P

Thank you for your solution, I tried it and it really works.
I think it can be an alternative way to solve this kind of situation.
In fact, it can solve some of the problems my team recently faced, but I’m curious that is it having any disadvantages such as security problems or whatever may have?
Currently, I only see the good side.

Thanks for your generous sharing.

1 Like

Glad to hear Opas. You may not face any challenges with security and i believe connecting to the organisation VPN gives you more security. Please anticipate on machine performance and network reliability. Cheers!!

1 Like

It runs on the CMD as Admin.
I created a .bat file with this command and when I want to disconnect the RDP session I just have to run the file as Admin.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.