Migration challenge from version 7.5 to 8

robot
studio
p_dev

#1

We got the below error while run the robot. Please assist

Cannot create unknown type ‘{http://schemas.uipath.com/workflow/activities}LogMessage’."


#2

Not 100% sure, but did you check if all the Packages are installed?

Most likely this


#3

The culprit is probably V7 compatibility pack. Prior to V8 namespace structure was vastly different.


#4

Hey thanks vvaidya,

But the core activities are all installed. Still the issues exists…


#5

How about as @andrzej.kniola suggested


#6

Thanks andrzej,

In my development machine, previously I have uipath 7.5 and developed 80% of project. Suddenly we have an update to use the latest version.so use the same workflow in uipath 8 and installed v7 compatibility to support the existing activities. And then i complete my remaining 20% of project in V8.

Everything was working fine while running in development machine. But when I try the same in robot run time machine, it shows that error message.

In run time machine, we have installed the latest version 8. Please advise how to resolve the issue ??


#7

What is namespace structure ???


#8

Do we need to install the same v7 compatibility pack into my runtime machine ??? Please advise what to do now ???


#9

Looks like not sure about the repercussions…calling @badita @andrzej.kniola @richarddenton

@bala0402 how many of these errors do you have in run time?

 <x:String>UiPath.Core</x:String>
      <x:String>UiPath.Core.Activities</x:String>
      <x:String>System.Windows.Markup</x:String>
    </sco:Collection>
  </TextExpression.NamespacesForImplementation>

#10

Not other than the below error. Only the error was stopped my running robo

Cannot create unknown type ‘{http://schemas.uipath.com/workflow/activities}LogMessage’."