Microsoft Office Intercorp excel error

Hi All, I found many topics with some different solution solving. I try run first project from academy starter in StudioX but received error:
Unable to cast COM object of type ‘Microsoft.Office.Interop.Excel.ApplicationClass’ to interface type ‘Microsoft.Office.Interop.Excel._Application’. This operation failed because the QueryInterface call on the COM component for the interface with IID ‘{000208D5-0000-0000-C000-000000000046}’ failed due to the following error: Error loading type library/DLL. (Exception from HRESULT: 0x80029C4A (TYPE_E_CANTLOADLIBRARY))

I have installed intercorp excel .dll via I added excel addin

My excel 2013 version is 32Bit but Windows 10 is 64 bit (It have to be like that for some other stuff)

Is It any option to fix this? I also tried repair office and re-install UI Path.

I used community licence for private learning.
I will not use code because I add only use excel file (nithing special) and used file from CurrencyConverter project.

Thanks for any help,

Excel addin is used inly at design time to indicate in excel. So if you get this error at runtime the problem is something else. Can you please describe or post a picture of you flow?

below screens my flow

I try run first flow from first training open excel file and read csv. I used file downloaded from your site

Hi kornel.jas, in the latest Community version[1] we have released an experimental tool which attempts to fix broken registry entries related to Excel interop. Could you please give it a try? It will also help us to validate our approach, since it’s difficult for us to replicate such issues. You can find it in Tools > Repair Tool for Microsoft Office Interop

[1] - UiPath Community 20.10 Preview Release



thank you. I run the repair process and now I can run my process without errors. Thanks for this implementation :).