Method not found: 'Void Uipath.IUiSelection.set_purpose(Uipath.UielementPurpose)'

I’m getting this message when I try to indicate on screen where I would like to use the type into activity and I also get this message when I’m trying to indicate what browser to attach to. It seems this is effecting my ability to be able to select Elements on screen.

Doing research into this on the forum I’ve found some topics that say they’ve been solved, by uninstalling packages, but they don’t say what packages to uninstall.
I believe this happened after the most recent Uipath update according to older topics people have posted, but again, It just doesn’t say what packages I need to uninstall.
Anyone know specifically what packages are causing this kind of interference?

give a try on the UiPath.UiAutomation.Activities

1 Like

When you say give a try on Uipath.Uiautomation.Activities you’re saying to uninstall it?

When I do that, I can grab a new type into activity, and it does allow me to select the text box that I want it to type into, but that messes up my entire script because now all the activities say they are missing or could not be loaded properly.

Do you have the latest System packages installed in the project?

The missing error is because vital packages are missing in your project. These packages are present when you spin up a new Project in studio. But if they are a bit older, you might have to update them in package manager.

1 Like

Uipath.System.Activities I have version 19.10.1
When I start a new project it sets uipath.Uiautomation.Activities to version 19.10.1
but in my project it was upgraded to version 20.4.3.
So I went into manage packages and downgraded it to version 19.10.1 to match the version
of Uipath.System Activities Version. When I do that, The activities that I’ve already placed in my script are still missing. So I upgrade Uiautomation activities back to version 20, but then I can’t use the Indicate element function because the method is missing.

You may have to downgrade another package to go with it. Usually, these are the ones that show up when you spin a new project:

image

1 Like

Uipath Studio 2019.10.1
Uipath.Excel.Activities = 2.7.2
Uipath.Mail.Activities = 1.7.2
Uipath.System.Activities - 19.10.1
Uipath.Uiautomation.Activities = 20.4.3 OR 19.11.0 OR 19.10.1

So I’ve tried all of the Uipath.Uiautomation.Activities versions.
I wasn’t having any issues with this in October or November. I just haven’t ran this for a little while, and when I tried to run my script in studio, I got the missing methods error all of a sudden. When I tried to run it the first time, it was unable to locate the browser because it was missing that method. So I tried to reselect the browser selector using the indicate on screen button, but it says that method is missing also.

So here’s what I suggest assuming you are using Studio and not StudioX (things may be a bit different ):

Rightfully,
Uipath.System.Activities- 19.10.1 should work with Uipath.Uiautomation.Activities

Open another instance of Studio. Create a new project.
Check what packages are being added by default to this new project.

There are two ways to go here:
Note down the versions of the new project packages and then upgrade or downgrade packages of your actual project to the same versions.
If not, pull your flow from the actual project into the new project and see if it works.

If it works in the new project and not in the actual, there is something off with the actual

I hope this helps because these two core packages should not be that troublesome.

1 Like

So This has a chart that helps you know what versions you should be running. I’ve checked what the highest version I can install is, and changed it accordingly. The highest version of Uipath.Vision is I have is 1.8.1. So I use that as a starting point on the chart and made sure the packages all match. When I do that it still says my activities are missing. It seems that they are tied into the most recent version of Uipath.Uiautomation.Activities. When I downgrade that all the activities go missing, but then I can’t use any of the activity functions like indicate on screen, and when I try to run it, it says it’s missing all these methods. Functions such as Uipath being able to find a browser or such. I think that has to do with the uipath.vision part of the package. I’m not totally sure what went wrong here or how to fix it. Any other ideas?

I tried creating a new package entirely, copied my two xamls over to the newProject folder. Activities were still missing because it was set to the Uipath.Uiautomation.Activities version 19 and I guess my activities that I have been using were part of the upgraded package version 20.

You may have to reconfirm this assertion because I’m working on a project with just the default packages. I looked up UiPath.Vision and I was able to install the latest version.

Are you sure you aren’t able to upgrade to the latest v2.2 version of the Vision package?