Message: Could not retrieve the result of the job execution. This might be because a message was too large to process

Were you able to resolve it? Yes, its a good practice to return only what you need and not everything.

I had same type error. I Read email using Imap activities. I tried to put that out using Arguments. I fixed it removing Out_Argument

Hi, it is limitation due to Community Edition?
Example: looping number of each folder (100 folders) in the folder?
Thanks.

I’ve had a similar issue today. The context was:
A loop which is appending the content of a series of text files to a string variable.
The text files are quite large, so I suspect it may be an issue with the size of the string it is creating.

NOTE for Anonymous:

DO NOT use IN/OUT argument with the UiPath.Core.browser with the close tab activity. This might cause this exception.

4 Likes

Do u have any solution? I need to attrach the same browser in sub-workflows

1 Like

I think this is buggy to use the out value when we are closing the tab itself. So avoid using close tab + out in such workflow. I think they should have a look into it. Idea it should return null and the out should be fine with it.

It is about handling the string values by robot. It seems like string variables are restricted with a buffer size so no matter you assign to a string variable or you write it to log, it will always fail due to exceeing that buffer.
Maybe UiPath may help us to understand the reason of that buffer limitation.
Thanks…

Also trace level logging is causing the error.

I think it is mainly related with a previous bug in writeline and log activities, link to previous thread is below.

It was fixed in studio side but it seems like it’s still valid on orchestrator/robot side. It may be related with message size while trying to log a long message to orchestrator (some table, json variable, web api response e.t.c). Usually if you enable verbose or Trace level logging, robot will try to log your long string to orchestrator then fail but if you keep log level in information then, I think you’ll overcome this issue. At least it worked for me… :slight_smile:

I’d appreciate your feedback about your solutions also

Thanks all :slight_smile:

I am getting this error but I am not clear on the steps to take, lot of information to process in here.

I have some arguments that are passing data dictionaries and Jobjects. Is this what could be causing the error and how would I fix it?

I tried adding the system.IO reference but doesn’t seem to be the difference

With the write line is this the total size of the output that occurs. Or one individual write line that is too large?

@ewanc1
I would recommend identifying the argument or activity causing the error first. Typically, it’s caused by a datatable or something coming in with too much information. - you can identify what is causing it by removing it temporarily

If that is the case, try adjusting the process so it’s not appending so much data to the argument at once.

Although, it’s easier said than done :smiley:

1 Like

hmmm not sure how to do this, it typically only happens if the process gets to the end successfully, and that will only happen if all the arguments are active. Bit of a catch 22 :roll_eyes: Also none of them are that large I don’t believe…maybe it’s the combination…

1 Like

When you log big amount of data like a collection or datatable it is a common behavour. Sometimes it happens even when not logging something but trace mode is enabled. Trace mode is actually another type of loggin so is pretty much the same as logging.If you have such problem, try to increase logging level for robot and try again, it worked for me.

Seems like I’ve already written a comment to this topic :smiley:

Sorry all

1 Like

My issue was passing an email message as an argument. It only had one attachment. Solved the issue whilst fixing another issue being unable to delete attachments after sending an SMTP mail.
Fix was in this thread
Dispose of attachments

using below activity with target object being the mailmessage:
image

1 Like

In Main.xaml when we are trying to send more data as OUT arguments we will get this of type of error.

We won’t invoke main.xaml by other file, It is good practice to avoid arguments.

So better declare them as a variables in Main.xaml. If it is really necessary to have the output in orchestrator job then only add OUT arguments.

1 Like

Although no orchestrastor, i encountered the same error like you.

Is this a variable size issue?

@caydel Thanks a lot

Thanks a ton. That solved the issue and saved my day!

Not only datatable, for that matter any Output Argument that is not received will throw up this error. I converted Daatatype and Browser arguments into variables to solve the issue.