Message: Could not retrieve the result of the job execution. This might be because a message was too large to process

It is really difficult to answer without more information about what is happening inside your workflow. What activities are you using and what are you trying to achieve?
At which point in your workflow does the error message pop up?

When in your process does it happen when you Debug the process step by step?

Hi @loginerror,

Even in Debug also the error appears, The error box appears after the completion of the workflow. The workflow contains Outlook activities, save attachments, do google ocr, do basic operations to split the string, and writing to excel file. I am using arguments instead of variables. The outlook mail output is defined as variable not as argument. This is the complete workflow.



I encountered similar error when attempt to do the certification practical question.

Any solution for the stated error?


First of all, I’m sorry for the slow response.
I’ve sorted out the reasons for this problem.
Because one of my output Argument types is DataTable and I didn’t receive it.


hi,Do you have a Argument that takes up a lot of memory that is not accepted? Please check your code.

Do you have a Argument that takes up a lot of memory that is not received at the upper level? Please check your code.


Thanks @caydel, your inputs helped!
I faced the same issue. My scenario where it failed was, a huge file was being read using Read PDF and was written into console using writeline activity. The issue got resolved once i removed the write to console.

1 Like

Thanks @caydel ! Worked perfect for me. It was due to returning a large datatype as an argument.

Is there a limit on the PDF size? Cause i am getting this issue when I am reading a pdf to txt. The size of the pdf is 1.5 MB. It is a system generated PDF and has about 250 pages.

Reading the pdf shouldn’t be causing the issue… Are you printing the read data into the console?

I am writing it to a .csv file with write text file and append activity. is there a work around for this?


Hi @RiteshJain1411

Are you receiving the same error as in the topic title? Could you maybe paste in the entire error message?

Hello, can the following comments help you?

  1. Whether to print this variable using [Writre Line] activity.
  2. Are there Arguments that occupy a lot of memory that are not received?
    I hope I can help you.

my loop was wrong, it was causing the data to be read many times which was causing the memory error. Its all resolved now. Thanks guys

I am getting the same Error and I am having a hard time figuring out which of my arguments is causing the memory issue. How did you resolve your issue? I do have a few datatables that I am passing in and out, do I clear all my tables prior to ending?

Were you able to resolve it? Yes, its a good practice to return only what you need and not everything.

I had same type error. I Read email using Imap activities. I tried to put that out using Arguments. I fixed it removing Out_Argument

Hi, it is limitation due to Community Edition?
Example: looping number of each folder (100 folders) in the folder?

I’ve had a similar issue today. The context was:
A loop which is appending the content of a series of text files to a string variable.
The text files are quite large, so I suspect it may be an issue with the size of the string it is creating.

NOTE for Anonymous:

DO NOT use IN/OUT argument with the UiPath.Core.browser with the close tab activity. This might cause this exception.