Message: column name 'Cash In' does not belong to a table

uipath

#1

Can someone tell me what I am doing wrong here. This is the AnyTellerDemo application trying to pull the cashin and notonuscheck from Excel to AnyTeller Application.


#2

Is the option “IncludeColumnNames” checked in Read CSV activity?


#3

Yes it was defaulted to it.


#4

@Sohaib786, Confirm these things once,

  1. Check your CSV Column Names containing any space(s) ?
  2. Are you reading the correct sheet where your column is present ?
  3. Any spelling mistakes while accessing your column name ?

Note: If not, sharing your excel/xaml/screenshot would be helpful.

Regards,
Dominic :slight_smile:


How to handle this exception
#5

@Dominic Please see below for screenshot. Your 3 criterias I have checked.


#6

@Sohaib786, can you print and check the datatable by using Output Data table Activity and display it to a message box/write Line ? Share the result if possible !

Note : Possibly uncheck the IncludeColumnNames Property and try with index of the column name

Regards,
Dominic :slight_smile:


#7

@Dominic I have used Message Box and it is empty. In my message box I had put dt.ToString Please see below:


#8

@Sohaib786, you haven’t assigned any output variable in output data table activity

Regards,
Dominic :slight_smile:


#9

Hello, I have the same problem as Sohaib786, that ’ Column ‘CashIn’ does not belong to table.

@Sohaib786, did you find a solution?


#10

Hello. Try to change Delimiter from Comma to Semicolon in Read CSV activity.

Regards, Peter


#11

Hi, did you find a solution for column names that have space in it? Thanks!