Message: Access Denied. (Exception from HRESULT: 0x80030005 (STG_E_ACCESSDENIED))

Hi, what does this error code means? There are no results for this error code in the forum. Kindly assist. Thank you.

What are you trying to do @sangasangasanga?

Have you tried to google the error code :slight_smile: , there will be lot of solutions available for the same error code

May i know where does this error occur in the process,i.e., with which activity
Cheers @sangasangasanga

I was testing out Balareva.excel.charts activity to create a pie chart in excel. There’s only that activity in the workflow. I tried googling but in vain.

Error message:
RemoteException wrapping System.Runtime.InteropServices.COMException: Access Denied. (Exception from HRESULT: 0x80030005 (STG_E_ACCESSDENIED))
at BalaReva.Excel.Charts.PieChart.Execute(CodeActivityContext context)
at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.ActivityInstance.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

@sangasangasanga The problem is with the permissions.
For remote client connections, the permissions needed to be given to the Network service.
Are you using the flow in any restricted environment??

May be you are trying to access the file from shared environment @sangasangasanga

Can you try to copy it to the local and open manually?If it works, then use the local file

@WhenCutEsh I am using an internet machine to try out.
@HareeshMR I am using a local file in my desktop

Then it will be network service issue :slight_smile: .

Do these steps

  1. Open Internet Information Server (IIS).
  2. Navigate to Application Pools > DefaultAppPool > Advanced Settings.
  3. For Identity replace the NETWORK SERVICE to a network user with full control over the network share.

I am sorry, I don’t get you. Why is this a network service issue? I am just using wireless sg network.