Managing packages error.((ActivityTimout Exception)

I have a process that catches (ActivityTimout Exception ) in try/catch activities. It was developed in 2018.2 and we just upgraded to 2018.4.3 ( to be exact). When I open the process on updated studio, my try catch workflow did not show up. I’ve tried managing the packages by degrading and re installing.
Has anyone else seen this error before?
Any quick solutions?
I have re installed the studio just to check.
Tried managing Most of the Path activities. NO luck.

image

Could not resolve type ‘http://schemas.microsoft.com/netfx/2009/xaml/activities:DelegateInArgument(ActivityTimeoutException)’ because could not find one or more of its type arguments. Row: 537, Column: 38

Could not find type ‘UiPath.Activities.ActivityTimeoutException’ in assembly ‘UiPath.Activities’. Row: 534, Column: 32

Thanks

I think you are getting this error because some activity is missing in UiPath Studio, you need to download from manage package.

Hi @Pema_Sherpa

Indeed, you will need to install the required dependency from the package manager.

What specific package will that be ? I have tried installing, downgrading and re installing most of the packages.

Any chance you could share the xaml file from before it was converted?

I just fixed the issue, but it is strange how I fixed it.
The logs error says " Cannot find ActivityTimeoutException". ( I had used that as a catch exception in my TRY/CATCH activity).

Since I had a backup of old code. I reopened the old code in v2018.2 ,removed my sequences out of try catch activity and deleted the empty try catch. Saved it and reopened the code in v2018.4 and had to re add the try catch. I could still find the “ActivityTimeoutException” there.
Why would it say could not find when I could find it?

It would be awesome if you could share the bit that caused the error (feel free to remove the sensitive data/screnshots), just the old xaml file.

I suppose something in particular failed during import/conversion to the new version. Hard to tell what exactly without seeing it :slight_smile: