Manage keyboard shortcuts in 2018.4+

Hello Community, in previous versions of Studio it was possible to manage keyboard shortcuts of Studio by editing in %appdata%\UiPath\UiPath\keyboardmappings.xml file.

Starting from 2018.4 version there is no such file, and no apparent place where it can be modiffied. How can I disable/edit certain shortcut in Studio?

1 Like

Hi @Sparrow

I’ve just tried it and it is here for me on 2019.4.1:

Maybe something got corrupted on your side?

Thanks for the tip. I’ve checked on another stations with 2018.4.5 version installed, and no luck. There is no such file (enterprise version).
I’ve made a clean install of community edition on a clean station, and there’s no such file :O. Could you please provide a sample keyboardmappings.xml file? I’ll try to insert it manually.

Strange, see below then:
keyboardmappings.xml (11.7 KB)

Thanks, unfortunatelly it didn’t resolve my issue. Meanwhile I updated studio to 2019.4.2, but it didn’t create the file. Now I’ve placed edited keyboardmappings.xml, but it doesn’t work The original keyboard shortcuts get triggered even if they were removed from the config file…

Hi @Sparrow

A few things. First, could you try to simply search your harddrive for this file? keyboardmappings.xml
It is possible that it is simply in another location (this idea comes from some research I’ve done).

Also, there is a bigger improvement to shortcuts coming our way (no promises on the exact deadline though). You will be able to edit all shortcuts directly from Studio with a bunch of other cool shortcut-related improvements :slight_smile:

Searching for the file was one of the first things I’ve done. I’ve inclued system and hidden folder as well. There is no such file.

I understand there are a lot of users that love customization but sorry its no longer possible

Starting with v2018.3, the keyboardmappings.xml file has been removed and the possibility to customize keyboard shortcuts has been deprecated.

That is ok but, currently some shortcuts are conflicting standard diacritic characters and make it impossible to type naturally. Maybe it shoul be reconsidered.
For example polish letter ‘ć’ (alt gr + c) triggers recording in studio while typing. This is quite annoying to close recording, type single characters in a different place and copy-paste them into studio…


Hi Sparrow,
Thank you so much for your valuable feedback.
I personally did not know such problem could happen for Polish IME, and now that I know, I can see it happening for other languages as well…
I will provide this feedback to developers.

1 Like

I have same issue with Czech Keyboard. UiPath totally ignoring ALT GR key, taking it as regular ALT if its matchignto some shortcut. So i cant use some special signs because its starting recording, or other UiPath actions, etc.

Any quick fix or workaround besides switching to ENG language keyboard?


Hi Toxi-K

So I actually looked into this. I wasn’t able to find a quick fix.

The devs are aware of this issue but I can provide any details about the delivery of a solution.

Based on my googling, I suppose you should be able to play around with below, and you may be able to disable our hotkeys. I haven’t tested it, but if it works, it will be great if you can share the solution here.

It’s not about the “loving customization” but more about the ability to work on different devices and environments without the local issues. It would be great if the feature will be back. Thanks a lot.

1 Like

Is there any progress on this? Only way to write @ on Czech keyboard is AltGr + V. Which is currently also an shortcut in UiPath - this makes working on a process (with emails) VERY annoying.

When automating legacy desktop software, many of them use F3 for searching the values. I am unable to use F3 while recording. :pensive: If it is possible to customize the short key, I can continue…

@Yoshi_Akiyama any updates in this matter? I’m polish user and I can’t write i.e.: annotations in my language, because ALT GR + C or A or S or E are hardcoded shortcuts in Studio, but in polish they are for characters Ć, Ą, Ś, Ę. It’s really inconvenient, still not to be able to change this in 2021.

1 Like

Nothing new… :frowning: As a workaround you can use diacritic symbols assigned to shortcuts (alt+a, alt+s) in edit window (you need to expand propery expression text box into edit window.

1 Like

It’s indeed an existing issue that we are aware of and one that I’ve actually reported myself a while ago. I can see that the related ticket is getting closer to being processed, but can’t share exact timeline just yet.

Hopefully soon :slight_smile:

1 Like

Could you please let us know about this experience in the latest versions? The buggy behaviour should have been addressed.