Make sure UiRobot is running as a service! errror while running job

robot

#1

Hi All,

I am getting this error -Make sure UiRobot is running as a service! while running a job from Orchestartor. As other suggested i tried to find “UiRobot” service under services.msc but i did not find any such service.
I restarted my machine and tried again and got same issue.
UIRobot is connected and running. Orchestartor is all set also. Any ideas how can i fix this…


#2

If you can’t find the service, then you should re-install. Install with a user with Admin rights.


#3

Thanks @RRajkumar. I believe the services should be available and running for community edition. I am currently using CE.


#4

I don’t think CE versions have support to run processes from Orchestrator.


#5

Thanks. i just installed the free trail version… Services is availabe and running now… While running the job from Orchestrator -https://demo.uipath.com/
i am getting this error. I have admin privileges for my system and not sure why i am getting this error.
Info : “Execution error : System.UnauthorizedAccessException: Access to the path ‘C:\ProgramData\UiPath\Projects\RS_Test123.1.0.6462.29480\lib\net45\gdp_country.csv’ is denied.\r\n at UiPath.Core.Activities.ScopeActivity.OnFaulted(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)\r\n at System.Activities.Runtime.FaultCallbackWrapper.Invoke(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)\r\n at System.Activities.Runtime.FaultCallbackWrapper.FaultWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)”

Any help is highly appreciated.


#6

Looks like relative path issue. Check if you have this file in the specified location.


#7

Thanks @RRajkumar: I went to the location and deleted teh csv file manually. After that job is able to create new files… Not sure what was the issue though… Again appreciate your help.


#8

I don’t even see the service. the Ui Robot is there in ‘C:\Users\Sourav\AppData\Local\UiPath\app-18.1.2’ path not in program files (x86). I’m getting the same error when try to run from orchestrator.
Please help.


#9

Can we complete the advance training in uipath academy with out the orchestrator support?