Make Public still included in Publish


I’m working on migrating our code to a new environment and using the latest UIPath Studio. In order to exclude XAML files, we right click on the file and select “Ignore from Publish”. It looks like in the latest version, that option is now called “Make Public/Make Private”.

I am trying to publish a library that has a number of files set to private but the publish is failing on one of the private files because it is trying to include other private files. The same code in the old UIPath studio publishes fine. Is this a known bug in version 2021.10.5?



Hello @carlor!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly

Well, the official reply from UIPath was useless. The only thing I found that worked was to include the main file it was complaining about so that all the other non-included xaml files would “compile”. I was able to build the library, but this is only a bandaid solution.