Machine Name and Machine Key unavailable in Orchestrator Settings - Assistant

Hello everyone,

I’ve installed the studio (Pro Community) on my computer and tried to connect my robot to orchestrator.
The first steps therefore would be to open the orchestrator Settings, copy the Machine Name and create a new machine in UiPath Orchestrator.

Normally you would have the following options:

Connection Type;
Machine Name;
Orchestrator URL;
Machine Key;

My problem is that this is not available in the orchestrator Settings. I can only see the “Connection Type” and the “Service URL”.

I suppose the Connection type should be changed from “Service URL” to “Machine key” but I didn’t find any information on how to do this.

Hi @burje.andrei,
The way you are describing is an old way of connecting Robot with Orchestrator. Correct machine name and user should be searched using “whoami” command in CMD not in Orchestrator Settings. Orchestrator Settings on your screen is the way where you need to fill out with all data you get.

Anyway you don’t need to do this as since latest Assistant updates you can just log in to Assistant using SSO and your Robot connection to Orchestrator is done automatically what actually happened to you. Just observe that you already have status “Connected, Licensed” :wink:

1 Like

Hi Pawel,

Yes, you’re right. The method of connecting must have been changed compared to the academy course. I’ve just tested it and the connected robot works fine.

Many thanks!

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.