Machine:Machine Template - Robot:Development Floating robot -Issue:Robot Unavailable

Hello Team,

I have been trying to connect my local UI Robot to orchestrator for a machine type :Template machine and robot type : Floating robot - development type ,but i am unable to do so. I get a message robot unavailable (Robot does not exist -when mouse hovered) in local ui robot. However, My UIRobot gets connected,licensed for standard machine and standard robots,Following are the more details

  1. I am using Community version
  2. Accessing orchestrator from “
  3. I have followed and done all the configurations as per UI path documents and videos on floating robots.

Following are the screenshots
–Screenshot of the floating robot and cmd

–Screenshot of the Machine Key on and UIRobot local configurations

-Screenshot of the Orchestrator version

Any help would be appreciated :slight_smile:

Re-provision the robot and try once:
In order to re-provision the Robot, you can follow the below approach and share the outcome:

  1. Disconnect the Robot from Orchestrator. Quit the Robot from the tray.
  2. Open Uipath Robot service As an Administrator .
  3. Restart the Robot Service (RUN-> Services.msc -> UiPath Robot -> Restart)
    4- Delete the Robot from the Orchestrator.
    5- Provision again the Robot in Orchestrator , pass the required credential details.
  • Robot unavailable - this status is displayed along with one of the following tooltip messages on mouse hover, in the following cases:
    a. “An Orchestrator Robot definition must exist for this user.” - if a Machine that hosts the Robot is not defined on Orchestrator. For example, if you deployed your Robots using the ConnectionString without first defining the Robots in Orchestrator.
    b. “Robot does not exist.” - when no Robot is defined.
    c. “There are no available licenses on the server.” - no licenses are available in Orchestrator.
    d. “Robot already connected to machine ‘Machine_Name’.” - a floating Robot is already in use on a different machine.
    e. “The machine key is linked to another machine!” - the key you used to connect to Orchestrator belongs to another machine in Orchestrator.

thanks for the response! @Akash_N_Jain

I tried the above steps but UI Robot status still remains Robot unavailable

Can you share full screenshot of license and machine page from Orchestrator

There you go.

These types of Robots only work with Active Directory users and are useful if the machine you want to add a Robot to has a different name each time it is spawned, such as for Non-Persistent VDIs. Same goes for hotseat environments, where different people are working in shifts on the same computer.

1 Like


I tried now with an Active directory user and i am able to connect orchestrator to ui robot for floating robots.

Thanks for the quick tips !! :slight_smile:

1 Like

@Dhingra08 - Can you mark the answer as solution pls:-) thank you

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.