Lotus Notes Mail Activities beta problem with ID and COM

I am in testing with the new “Lotus Notes Mail Activities beta” Modul.
Now I became error messages return from Lotus COM Modul about the ID File (can not open the file).

Gives a specification for this Modul? or a solution for this problem? We have here Lotus 9.0

Message from UiPath Studio:

Source: Send Lotus Notes Mail Message

Message: Notes-Fehler: ID-Datei konnte nicht geöffnet werden

Exception Type: System.Runtime.InteropServices.COMException

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
System.Runtime.InteropServices.COMException: Notes-Fehler: ID-Datei konnte nicht geöffnet werden
at UiPath.Mail.Activities.SendMailActivity.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)



@UPDATE: With other PC’s is the same problem, the file as such I can open also Lotus itself has no problems. The encryption of the file is 128-bit RC2 (if this is important)

1 Like

Hello @PeterTo,
Lotus activities are quite similar like the Outlook. This means that you need to have Lotus opened and user logged in during performing the task/workflow. Additionally what does not exist in Outlook activities you need to provide password for the mailbox (it doesn’t matter that it’s opened already).

1 Like

Hello, Pablito,
thanks for the answer and the info.
I’ve just tested this, but still get the same error message.
Does something special have to be activated/installed in Lotus?

Remember to have Mail opened (not only application). If you could show the workflow (just remove username, password and any sensitive data) I could take a look on it.

Hello Pablito,
yes the mail it’s open. I have testet with and without open Lotus Mail.

Here are the workflow from me:
Lotus_Mail_Send.zip (10.6 KB)

We have a special by opening from Lotus, the ini file it’s on a other place (see arguments by opening programm).

Thanks a lot for your help


I think that problem may occur just at the beginning:
Can you please try to remove section about opening lotus and try if only sending mail one is working for you?

Do you mean just run only with the send modul als example and Lotus is already open in mail modus?
if yes, unfortunately that did not work either.

Main.xaml (5.0 KB)

What is this ID file? Is it an attachment? Or is it part of the Lotus Notes system?

the ID file is a indification file form Lotus Notes and a part of it (and encrypted / confidential).

Hello Pablito, do you have any idea how to solve the problem?



Hi @PeterTo,
In this case it’s really hard to find out where the problem is. This is the first time someone have this kind of problem. What else you could try to do is to check if changing ID file encryption will change anything, Try to test it with newer version of lotus. And also check if Studio beta channel has solved the issue in newer version of dependencies.

together with a colleague we could now find and solve the problem. In the registry the reference to the ini file was incorrect, after a change the module now goes so far.

However, I get this message when I retrieve the file:


Tested with 1.4 and the Alpha 1.5

The message it’s comming after read out more then five mails.

Do you have a idea for a solution?


1 Like

Hi @PeterTo

Please don’t hesitate to contact our technical support for more assistance, they will be able to escalate it in case it is a bug in the activity package.

1 Like

I will do this, thanks for the info


My problem was that in the registry of Windows the wrong ini file was specified for Lotus Config.ini file.

The change to the config file is usually done by changing the parameter in the link to Lotus Notes.
However, this does not help UiPAth, you have to store the correct path in the registry.

This was at least the solution for me and hopefully also for you.

See you



Thank you for sharing the solution with us :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.