Losing extract table data

Scenario is simple

  1. I successfully configure via “extra data wizard”
  2. Test extraction shows all the data properly
  3. i refresh the page
  4. Extract data stops working and i get following message with “test extraction”:
    image
    When i do “edit extract data”, no elements are recognized and i have to reconfigure it → on refresh lost again.
1 Like

Hey @werkwolk

You are trying to refresh the page when the bot run or ?

Thanks
#nK

Hello Nithinkrishna,

The scenario is done @ design time. I need to double check, but don’t think you can “test extraction” @ run time.

The result is the same though @ run time. Once i finish designing → testing with “test extraction” → ok → run → no data to extract

I’m a step closer, need to do more testing/debugging first to make conclusions, but i remarked a “chat/box/popup” on the bottom right of the site. I didnt think it would change my actual element/anchors, but once I blocked that chat bar with “adblock”, i’ve been able to get the data multiple times in a row now.

Edit: all my tests so far indicate the prob is related with that specific “chatbox element”

The real Q is then, that same bar is there at design time. Even when adding delays to emulate human behavior during run time i lose my “element/anchors”.

Can you please post the screenshot it will be clear to us for which bar you are talking? @werkwolk

image

Personally i think i got an answer to the issue here and the thread can be closed. It’s definitely related with DOM changes @ runtime and if needed i can put in more time to find specifics.

It seems the problem resides elsewhere…somehow it worked a few times in a row…and suddenly stopped recognizing the table again.

i removed practically everything not related to the table with an element blocker, so basically what i see is only the table. I indicated the columns also in this view.

1 Like

So the issue is resolved @werkwolk ?

no its not unfortunately

my final test with edge did work again, i’m going to keep testing with that browser and try to exclude anything browser related. but edge is chromium based and it didnt work with chrome.

in any case, 'ill see where thsi goes

1 Like

Sure @werkwolk