Lookup and match not working for two numbers that are the same

I have a SharePoint site that I want to compare to a list scraped from a website to make sure that only the new items on the website are uploaded to the SharePoint site. I did the read list for SharePoint and pared down the dictionary to a data table with just the identifying variable that I want. It’s a nine digit number that I pass through as a string. I have an activity that scrapes the data from the website into a data table. I have been trying to use Lookup Data Table to find the value from the SharePoint site in the data table from the webpage, but it’s not returning a positive result. I’ve tried everything I can think of to make sure the values are the same type, lookup only allows string, so I tried to make sure they were both strings. Neither value has an extra space or anything else I can see that would prevent it from matching. I also tried iterating through the second data table with a for each to check line by line that the value existed, but it’s not matching that way either. Any idea how to get this information to match? I need to remove the rows from the second data table where it finds a match so that they aren’t processed and added to the SharePoint site later in the process. Screen shot below is from the run log showing a lookup value from SharePoint and the result value from the web scraped data table and that it’s not matching.

Never mind. I finally realized there was a bit of white space at the end of one of the variables that was interfering.