LoginToConsole RDP problem

Hi,

We have a very large ReFramwork workflow integrated with SAP.

When it runs every 5 minutes via a trigger in orchestrator and I’m logged on to our server as User X for example, the UiPath Agent triggers the workflow accordingly and everything works as expected and I can see all the relevant SAP screen being filled, etc…

Unfortunately, everything falls apart when the workstation is locked. We’ve started addressing one issue at the time i.e. SimulateClick, and other problems but started to encounter more problems i.e. SimulateType for the TypeInto for example. As we have a lot of workflows, this will take forever to change, not to mention to re-test, so this is not a solution.

After researching this some more, we thought we’d have a solution by using the “Login Into Console”. We enabled it and tried both scenarios when set to “yes” or “no” but it still seems to be running the process as a background process (Not sure if this is correct) but I’m still getting issues with the likes of the TypeInto, etc…

I thought that when it was set to “yes”, it would end the current RDP (if any) and start a new one and the workflow would be triggered as if I had an RDP session running as User X and everything would work as expected

but

a) my session with User X remains opens and
b) the workflow no longer gets triggered in the foreground as it did before when the “Login to console” was disabled. When I lock the workstation on purpose to test it, it still run the workflow but as I said, in the background causing a bunch of errors!

Any reasons why my session is not being ended by orchestrator when the process is started and why the workflow appears to be running but as a background process rather than in the foreground one.

I’d appreciate any help.

Thanks,

Thierry

1 Like

@tfierens1

  • are you using attended/unattended robot?
  • Is it community/Enterprise edition?

hi @tfierens1
First of all i hope you are running this process by using Unattended robot,

when you wanna connect via RDP you should have loginToConsole: false
When you wanna connect via directly you should have loginToConsole: true

using or editing Login to console , i hope there is nothing to do a work form there as because of you are mentioning as you are using SAP application,

Login To Console

Enables the Robot to connect to the console session of the machine where it is installed. Additionally, it indicates if you can connect multiple Robots to Orchestrator using multiple users ( High-Density Robots ) or not. By default, the value is No . To enable High-Density Robots, set the value to No .
If set to No , the Unattended Robot creates an RDP session when executing a process. :copyright:
Refer : https://docs.uipath.com/orchestrator/docs/robot-settings

@Maneesha_de_silva thanks for getting back with some feedback but i’ve already tried everything you suggested and I’ve also read the link you provided and more but for some reason when I set the LoginToConsole to false (or true for that matter!), I get the mentioned errors where I’ve had to change a standard click to “simulate” or a standard TypeInto into a TypeSimulate, and so forth.

I’m not sure what you mean by “work form”. I’ve seen it mentioned in some of the documentation but I don’t think it applies to me as I’m using SAP 760 desktop application.

My LoginToConsole is definitely enabled and set to “false”/“no”, so why isn’t it kicking me out of my session when logged in. Maybe it is because I’m logged in as the same user as the bot but then you would think it would work if i locked the workstation and let the bot do it’s work but I’m still getting errors.

Remember that when I’m logged as the same user as the bot, I can see it being triggered and it is 100% error free.

Any other ideas/suggestions?

Thanks.

Thierry

Hi @GBK,

I’m using an unattended bot with the Enterprise edition.

Thanks.

Thierry