Login error

I am trying to log in a CRM application through RPA but when I run the UI Path, it gets stuck on the log in page itself. It’s a Microsoft dynamics crm 365 application.After filling the login id, it redirects to fill the password and there RPA Unable to find the password field and signin button to proceed further as I think the password window loads dynamically each time in MSD Crm.

is there any constant term near to the password field so that we can choose that as anchor and enter the password using ANCHOR BASE ACTIVITY
Cheers @nole_1

Are you able to use sendkeys to navigate to the element? (tab)

In order to help provide a better solution, please send a screenshot of the available selectors for your password element.

Hi @nole_1

Are you saying that right after the user ID is given it redirects to a different screen where it tries to enter the username and the password?

If that’s the case, have you tried introducing a on element appear activity and check whether the text box to enter the password is available before actually trying to enter it?

In side the on element appear, you can have the type into to type the password and the click activity to click on the login button.

Let me know whether this works for you?