Loading asset UiDemoPath failed: Invalid asset type was specified for asset '{0}'

orchestrator
robot
activities
studio

#1

Hi all,

I am currently going through the advanced level training course involving the usage of UiDemo app. I have followed through all the steps in the walkthrough and I got the error mentioned above. I did the debugging steps and found that the error came from the “Try Get Asset” portion (that was where the log error was printed). Please give me some advice on this.

Secondly, I would like to ask what is the difference between reading the asset from the excel config file and getting it directly from orchestrator asset tab? This portion kinda confuses me.

Thanks for reading!

P.S I have compiled all the images into one image.

EDIT:
I tried using my friend’s identical project (whose project is successful in running) to run on my laptop. I got the same error again. Could it be some dependencies or package issues?


#2

As shown below under message low on the bottom right, it says Get Asset faulted. The next step results in the log message saying that the asset type was invalid.


#3

You need to use Get Credentials to fetch Credentials. Get Asset won’t work for Credentials.

Also, you can set asset values using Set Assets and Set Credentials.

image


#4

Thanks for the quick response.
Im afraid I didnt explain my issues properly.

I have to run _test.xaml to test whether my initallapplications.xaml reads config file and invokes file. However, log message shows:

{
“message”: “Loading asset UiDemoPath failed: Invalid asset type was specified for asset ‘{0}’.”,
“level”: “Warning”,
“logType”: “User”,
“timeStamp”: “18:59:20”,
“processVersion”: “1.0.6885.21320”,
“jobId”: “ad0d7a0e-1982-4917-a09f-f6da1df66fac”,
“robotName”: “UiDemoPath”,
“machineId”: 52161,
“fileName”: “InitAllSettings
}

Thus, this has nothing to do with getting the credential because it is entirely differently from getting Assets. To elaborate further, I have to get the Asset from the config excel file. However, it reads but it detects empty rows?


#5

Hey, If you are using the assets sheets then you have to do it differently.

Setting sheet:


Asset sheet:

Try this it should work.


#6

Hey! Thanks for the help!
My settings and asset settings are the same as yours and the error is still the same after running _test.xaml.
If there is anymore information you need in order to help me troubleshoot this, please do tell me! :slight_smile:


#7

Please show me what your config sheets look like.


#8

Config.xlsx (20.2 KB)


#9

I had a look at your config.
So you have

Settings:
UiDemoPath = C:\Users\u91137\Desktop\UiPath\UiPath Advanced Training Course\UiDemo.exe

Assets:
UiDemoPath = UiDemoPath

Now do you have an asset created on your orchestrator with name ‘UiDemoPath’?
And if yes what is the value

Secondly if you are using Assets tab to get assets from Orchestrator then the Settings tab value
UiDemoPath = C:\Users\u91137\Desktop\UiPath\UiPath Advanced Training Course\UiDemo.exe
is not at all used :slight_smile:

So if you are using Settings tab to get the path then you dont need Assets
If you use Assets then create an asset UiDemoPath, Text type and dont need the Settings entry

Let me know if its making sense.