Loading asset UiDemoCredential_ReFramework failed: Invalid asset type was specified for asset '{0}

Hi Guys,

I have been facing an issue on when I try to work on UiDemo exercise.

I created an asset with the name UiDemoCredential_ReFramework.

I gave this asset name in the Config file (Assets sheet) and I am trying to get username and password using in_config but I am facing this error.

Credential type is given as Credential in the Orchestrator too.

Please share your workflow.

1 Like

Hi Vivek,

I am a new user and wont be able to attach any documents here.
I was actually trying to work on UiDemo example from Advanced training.

1 Like

In your config excel you should add two col one is name -> which you access from Uipath studio and value -> asset name
While you extracing you should pass argument as config(“name(name you specified in config file)”).ToString to get asset activity in input parameter

Hi @pippug,
I faced the same while I was going through the same example. The solution to this is as follows…

In the config file assets tab, you should only mention assets which are not in the type credential. All the credential type assets should go into the settings sheet which is the very first sheet of the config.

The reason to do that is, in the Framework, it uses a get asset activity to read assets that are mentioned in the asset sheet. Since credential is a asset that should be read using get credential activity, it throws an error there…

So removing the credential asset from the asset sheet and adding it to the settings page should work fine for you…

Let know how it worked out for you…

20 Likes

Thanks @Lahiru.Fernando . I was facing the same issue and was searching forum for the answer.
Came across you solution and it worked.
Thanks again.

4 Likes

You are the man Lahiru! I was facing the same issue! It worked

3 Likes

Thanks Lahiru.Fernando it worked.
Was faicing this issue.

2 Likes

You are welcome @aov :slight_smile:

1 Like

Thanks Man!!! I wasted so much time not knowing this…Finally, your answer gave me hope.

2 Likes

Thank you @Lahiru.Fernando. Its worked properly

1 Like

@Lahiru.Fernando sir can you help me out to solve this error. when I’m executing project it throws this error
Get Credential: Object reference not set to an instance of an object.

1 Like

HI @Vrushali_Gave

Sorry for my late reply. Just now I got a chance to check the messages. So for this error, Can you check whether you are passing the proper Asset name? I think you are using the REFramework for this right? So you must be getting the Asset name from the Config file. Can you check whether the In_Config argument is properly set to refer to the proper asset name?

Yes, sir, I am using REFramework for this project and I was putting the wrong asset name so it gave me that error. Thank you sir that error solved.

Thanks
Vrushali

1 Like