Loading asset Credential failed: Could not find an asset with this name. Error code: 1002

Hi, I tried all the possible solutions provided on forum. Please help me to resolve this.

Asset Name in Orchetrator and Asset Name in Uipath should be same.

Please follow below tutorial


I hope ur issue is resolved by now…

If not please make sure your local machine i.e. laptop or pc on which UiPath Studio is installed in connected with Orchestrator… Once that is done then make sure Asset name & everything is correct…

I was stuck like you and after following all the available instructions on internet i was still not able to continue because of error 1002. Suddenly these thought clicked in mind and after trying it worked.

Follow below steps

  • Log in to https://platform.uipath.com/
  • Go to “Machines” tab >> Click on “+” button
  • Click on “Standard Machine”
  • Enter Machine name as Computer name (Check Computer name by going to “Control Panel\System and Security\System >> Computer name”)
  • Click on Create button
  • Click on “i” icon & copy Machine Key
  • Now click on UiPath robot icon available at left bottom side of Computer screen
  • Click on Settings icon
  • In Orchestrator URL enter, “https://platform.uipath.com/”
  • In Machine key field enter key copied from Step 2
  • Click on Connect button

Hope it solves ur issue if not solved already


I had initially created the asset in the damn Shared folder (I hadn’t noticed this detail).
When I have re-created it in the Default folder, Studio managed to find it.

Late reply, but maybe it could still help.


I know this is a very very late reply…

But you can navigate to different folders and retrieve assets in Orchestrator by putting the folder name in “Orchestrator Folder Path” property of “Get Asset” activity.

For example, if I have an asset “GetNotepadValue” in my orchestrator in folder “Test” (so not in default folder), in the “Orchestrator Folder Path” field I will put “…/Test” and it will retrieve the value from “Test” folder instead of Default folder