'Literal<Dict Literal only supports value types and the immutable type System.String. anyone ever experienced this error before?

Invoke ProcessTransaction workflow: The following errors were encountered while processing the workflow tree:
‘Literal<Dictionary<String,Object>>’: Literal only supports value types and the immutable type System.String. The type System.Collections.Generic.Dictionary`2[System.String,System.Object] cannot be used as a literal.

Hello all so I have the above error when I am trying to do the dispatcher in the assignment 2 of the 3rd level of the academy. I have searched through google and the UiPath forum but no luck.
the UiPath forum has no hits at all the closest thing I could find is something describing a dictionary.

and google keeps giving me coding advice in Java lol.

Process.xaml (17.2 KB)
here is the process that has the error.

Its weird it never goes into the process.xaml the robot just like give the process.xaml a quick glance and says nope not running that.

I tried to adding the add queue item to a comment out activity but it still errors out at the same activity. with the same error

I do not understand the error… it is in a commented out activity and if I remove it I get the same error it just does not point to the activity

does anyone have any ideas?

thanks in advance,



This is something I’ve never seen before. But I found a fix. If you go into your Argument type in your in_Config and choose a different type and then back to Dictionary, it should work . It did for me when I ran your process.

Happy Codding



Thank you!

have a blessed day,




Everyday is a blessed day. Glad to hear it worked.

Happy journeys!


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.