Listbox not registering changes when using select, only when using type into

I have a couple of questions.
When I tried to execute action from dropdown listbox in a desktop application with “select” the application has not executed but when i used “type into” it is working. Is there a way to use “select” or “set text” for that purpose?
Another question: The desktop application has a function to copy the result from this action but when I am trying to automate this action it is working very poorly. The copying function is not working with “select” or “set text” but is only working with “type into” and it needs to use delays to be working. I don’t get a stable solution for this other than using an older version of my project from 9 months back. When I tried to change it from scratch now it was not working. It seems that Uipath is very sensitive for right settings in every element. Is it also sensitive for newer versions of Uipath?

I managed to solve the problem. It was possible to use “select item” in dropdown listbox but I had to have one “click element” before “select item” and one “click element” after.