License errors



Hi everyone,

I’ve gathered here most of the license errors that we have encountered during Studio activation. Please feel free to complete the list by replying to this post.

"Device Id already activated, trial not allowed after code activation"

After you have once activated a device with a license code in the past you cannot use the free edition on the same device - it is not an error, is expected behavior. After code activation, the device ID remains registered in the system and it does not allow you to go back and activate CE.

In special situations where the above should be approved (going to Community after using a trial or license key) you will need to reach out to support and give details on your request and also provide the device ID of the machine. If the request is approved, support will release the device ID from the system and it will be possible to activate CE.

"Certificate or receipt missing"
"No Error. License status: Server License Expired"

  • Community edition needs a refresh every 12 weeks. This means that you have to renew your free license by sending your details using this link: - only if you had never activated Studio with a license key, meaning you only selected Start free option the first time you activated Studio
  • The Trial license will expire in 60 days. After this period, if you want to continue using UiPath Platform, you will have to make a request here - select Service request - Licensing. - only if you had previously activated with a Trial key

"SOAP host can’t be resolved"
"Error connecting to activation server. Please use offline activation"

This error is due to the firewall blocking the connection between your machine and the activation server from UiPath.

“There was an error trying to reach the activation server. You might be behind a firewall. Please contact your network administrator and retry later. Optionally you can try Manual activation”

Try removing HTTP_PROXY environment variable from your computer… Details in this post: Error while activating UiPath Community Edition

"SOAP client has invalid date"

Update system date.

"Server returned invalid XML"
Try opening Studio with Administrator permissions. And also check if you are behind a firewall.

"NSL library could not be initialized"

Please check and make sure you have full permissions on %programdata% and the Documents folder in C:\Users\Public. If you don’t have admin rights on that folder please request them internally. If you can’t find the Documents folder in C:\Users\Public please create it manually. After this you should be able to activate.

"Error initializing licensing library"

Note: When you click “Activate license”(meaning if you have a license key), if you attempted to activate UiPath once but it was unsuccessful, then the License data was also written incompletely. In order to solve this issue and get Studio up and running please proceed to the below steps:

  1. Go to %program data% and delete the License folder from the UiPath folder - this will ensure you start a clean install
  2. Start Studio
  3. Select the “Activate license” option
  4. Insert the license key / trial key
  5. Select “Manual activation” and follow the steps described in the article below accordingly. Keep in mind that you will need to have access to a computer with an internet connection for manual activation.

Error when activating CE "Device ID already activated..."
Error attempting to activate license
UiPath community license got expired
Error while installation of Uipath community edition
UiPath Activation - Activation failed with error: -10000000
Activation UIPATHStudio
Unable to activate UiPath Community Edition on my personal laptop, error 4304
Unable to update CE edition
My trial period for community edition is over, can i renew/Activate my license again ? Please let me know
License Error!Device is Already Registered Error!
Get community edition after trial
I ever used activate license, and now switch to use free version, but occurs the error
Studio Activation Failed : Device ID already activated
Activation failed with error: -4303
Community edition
License registration error for installation of community edition
Trying To Renew UIPath Studio Community License
Uipath Change my Device Enterprise version into Community version
Activation failed with error
Activation Issue: I want to use community edition, please help me renew license
UiPath 2018.2.6 Error -4304
UiPath Community Edition Software Download file Issue
Activation Error for first time installation
Not able to install the UiPath Community Edition
Community Edition Activation Error activation server. Please use offline activation
Free License
Error to activate trail
Multiple UiPath Version Challenge
My Trial pack expired and i am currently not working so cannot provide company email id, can anyone help how to solve this
Not able to activate free licence key
Is there any file about uipath error?

My community version license has expired and I have tried all the above methods to renew, but it’s still not working. I have installed only community edition in my device and never installed other versions. Can you please advise?

Device ID: vzZGuwzsbGhejfmnabeY



Same over here,
Can not reactivate my community license:

Activation failed with error: 0
Error description: No Error
License status: Device ID already activated, trial not allowed after code activation
Device ID: eYWoESifcWwoN6Q9ipOp


Hi Tom,

Your Device ID is linked to a trial code that was activated on 24th December 2017. That’s why you cannot activate Community Edition(Start free option). Please reach out to support:

Unable to open UiPath

Hi, I have the issue “SOAP host can’t be resolved”.

As explained, it’s due to a firewall issue.

I can make a ticket here to ask for access to the activation server but I wasn’t able to find wich url/ip (or something else) is needed. Uipath website is accessible considering I managed to download the installer.

Thanks in advance

Activation failed with error: -4303

Please check the Robot documentation link in this post:



I have reinstalled my UiPath and still get the error “SOAP Connection timed out”
I can’t see any solution for this one here :confused:
I am attaching the screenshot of this error.


If anybody is able to help me I would be grateful.

Thanks in advance.



Hello Guys,

In my case the only thing that I had to do was switch to my mobile network.
After connecting with my mobile as a hot spot I was able to activate the CE license.
Btw. it worked for both CE .exe file and .msi file.

Hope it will work for you as well.

Best Regards,


Very good post, it will help most of the beginners


Hi, I have tried using my mobile network, however I still can’t activate. Please help urgently!




Hi @cclam81

Have you tried whitelisting the licensing server You can find details in this page of the Robot user guide:

Studio free trial activation URL

Hi @ovi, I just tried whitelisting on my Windows firewall, if that’s what you mean. However, I’m still facing the same result. Not sure whether I have missed anything here. Please help. Thank you.


Try to delete the License folder from %localappdata%\UiPath, start Studio again and try to activate.


Tried a few times but still unable to activate. I have already whitelisted the licensing server. Even tried disabling firewall. All of this is done using my mobile network. Please help. Thank you.



Same here,

It says i have already used the trial version when is my first time installing CE.

Device ID : IzcirznRTCyaLYg9f4xA



Please Ovi:

Error description:
“Cannot use Community Edition on this machine after activating a trial or Enterprise license code. Please enter a valid license key.
License status: Device ID already activated”

In the link "" say “Community Version users: Community Edition is provided by UiPath free of charge and we don’t offer support for it on our ticketing platform. Any inquiries from personal email addresses won’t be answered.”

Please your help :frowning:


Did you previously have a Trial license on the same machine? Are you using a VM?
Please provide your device ID.


Yes, on the machine I had a trial license. I do not use a VM.

Activation failed with error: 0
Error description: Cannot use Community Edition on this machine after activating a trial or Enterprise license code. Please enter a valid license key.
License status: Device ID already activated

Device ID: FI+r7IStwfyNxc17sdC/
Computer: PP01TCSPROAFP07
User Name: S80269

Please your help :frowning:


Hi Ovi,

I am experiencing the same issue as hapari_ch. I had previously downloaded the trial version of UIPath on my personal computer because I was part of a test user group for my organization to determine whether or not we wanted to purchase UIPath. My organization has since purchased several UIPath licenses for use at work, but I am now wanting to download the Community version onto my personal computer to program things for the Hackathon. (Corporate policy does not allow me to use my work computer to program for the Hackathon.) Unfortunately, since my previous Trial version of UIPath has now expired, I am getting the following error whenever I try to activate my Community version:

Activation failed with error: 0
Error description: No Error
License status: Server License Expired

My device ID is Bpxntv2j+aS2pUwHmWeG.

I would very much like to participate in the Hackathon, so please let us know what we need to do to resolve this!

(I have also submitted this as a request via the link, but as hapari_ch pointed out, the website says they will not respond to any inquiries from Community Version users, so I do not expect to receive a response there.)

Thanks in advance,