Licence Server Activation



I have installed UIPath Community Edition on my work pc to do a proof of concept. It does ask for licence activation and I get the below error


I have been told I have to give the server ip address and port to allow connections specific to my PC, but i dont know which server and port is the licensing server.

I have also tried “Automatic Activation” but i get the below error

Activation failed with error: -4007
Error description: Server responded to wrong function
License status: Undetermined

Device ID: myodOMaoJRi2Bq280XXXX
Computer: PC-XXXX
User Name: XXXX

Can someone please let me know how do i get past this.





Here’s a response from Uipath Team about the error that you’re facing.

Maybe can help you!



Hi @srinivass

Please try adding the license server( to firewall’s whitelist.


Can you please let me know the port number as well




I don’t know the port. I’ll look into it and get back to you asap.




Any luck on the port information




Hi Ovi

Sorry to bother you.

Can you please let me know on the Port as well.



Hi Sri,

Sorry, I couldn’t find it. My suggestion would be to disable antivirus and firewall just for the installation. It should work like that.


I wont be able to do any of that because I dont have any permissions on our system. I was told by the networks team to raise a change request giving the server name and port so that they exclusively allow access from my ip address. i will give a try with just the server address and see if it works.



Hi Ovi

Our networks team have asked me this

"Firewall showing dropped packets to various external addresses but all using https.

We need to establish whether this client software is proxy aware as https should be going through proxy."

Is the software proxy aware ? Is there any configuration where it picks the proxy server address and routes it.

Can you let us know




Did you find the port number?
Please revert if you did!



my networks team said they created a rule on the proxies to allow unauthenticated access to that domain.
and said they think that the software wasn’t passing any credentials to the proxy.

I could access only after that



Here’s the protocol list in case you need to whitelist something in your system:

Activation: (port 80)
Update: * (port 80)
Packages:, (port 443)
Orchestrator CE: (port 443)

I just found them yesterday.


Are these intended to have numbers at the end?



No, they are copied from another post and the numbers at the end represent the number of clicks on that link. :slight_smile:


I figured… was hoping they’d update the post :slight_smile:


I have updated it. Thanks a lot!


hi ovi