Library in Automation Created in Studio not publishing to Orchestrator

I have an automation that was working without issue and I recently did an update to it. When I made the new publish the Invoke Code broke and is giving an error System.ArgumentException: No compiled code to run error BC30002: Type ‘HtmlDocument’ is not defined. I am using the HtmlAgilityPack HtmlDocument but when i look at the orchestrator library there is no HtmlAgilityPack so I assume this is the root cause. The automation executes without issue in Studio/Developer Robot.

Hi @alexander.murray,
Welcome to the Community!
If this is non-official package then you need to be sure you’ve got the feed configured properly on Orchestrator tenant so the project will have the way to apply it.

Thank you, can you point me to instructions of how to do/verify this in orchestrator?

You need to go here:
image

Then check if you have enabled both tenant and and host feed:
image

And finally make sure the host on which automation will be performed have all needed feeds enabled.

1 Like

Ok two things,

One: when I switched to Both host and tenant feeds all the libraries in tenant->packages->libraries are gone.

Two: when you state “make sure the host on which automation will be performed have all needed feeds enabled” i don’t see any option to enable feeds in the UIPath Assistant Bot

I tried and both modes and there was no difference. still get the error HtmlDocument is not defined which would occur if the HtmlAgilityPack library is not there

Again, didn’t have this issue before migrating to the modern folder and new UIPath Assistant

Hi @radutzp,
Could you have a look.

It shouldn’t have to do anything with the upgrade of the Assistant.

From the looks of it, I would say that your Robot doesn’t find the HtmlAgilityPack package anymore. Now, there can be multiple sources of the problem:

  1. The feed configuration was changed upon the Robot/Studio update. Did you update via the Enterprise installer (MSI) or Community installer(EXE)?
  2. The feed configuration was changed in Orchestrator when switching from classic to modern.
  3. The package was somehow removed from the feed

Now, the fix would be to go to nuget.org and download the package (make sure you download the version that you need) and then go to your Orchestrator and upload the package manually. Here are the steps:


This should give your Robot access to the package again.

Let us know if this worked for you